I was trying to change my boot device on Ubuntu, but when I hold F2 (the key to enter my BIOS) Ubuntu GNU GRUB appear. I would like to know how to enter my BIOS so I can continue changing my boot device.

  • There should be a message at the beginning of the boot process before GRUB appears.
    – Manuel
    Jul 11, 2013 at 6:02
  • I have a hack if you cant get in, in time. Unplug your boot device. you will then get prompted to enter the BIOS
    – j0h
    Jul 11, 2013 at 19:39
  • Ubuntu definitely didn't replace your BIOS/firmware with Grub. So this is not related to Ubuntu and not reproducible (e.g. poor description and not useful to other users) either. Have a look in the manual of your mainboard or computer to find proper instructions.
    – LiveWireBT
    Oct 12, 2014 at 15:32

13 Answers 13


For those that might still stumble on this problem, the solution is:

When you start your PC, hold ESC, or you can hold ESC and then start the PC, doesn't matter.
A menu will appear. From there you can select which device to boot or to go into BIOS.


If you are to boot from a dvd or usb you can press 'c' at grub menu for a console then type exit and hit enter. It will boot on your dvd or usb. I was completely mad with this issue until I found this workaround.

  • 1
    Use quit for older versions of GRUB (0.9x in my case).
    – fjdumont
    Apr 4, 2019 at 9:49
  • Or use exit to get out of grub prompt
    – Wildhammer
    Jan 3, 2021 at 0:19

On a modern machine, from the grub> prompt use the command fwsetup to get back into your firmware setup (UEFI or BIOS config screen).

grub> fwsetup

Nothing else seems to get the attention of UEFI or grub during boot! Once in the UEFI setup you can then rearrange the boot order to put a working OS before grub, or drop to a UEFI shell to fix up your boot files.

  • This is the real answer. I couldn't get my boot menu or my bios to open with any key combos. This worked first try. Dec 30, 2023 at 22:35

On clicking the Power button, hold down ESC and continue to tap F2.

Or, in case that F2 is linked to your Fn:
On clicking the Power button, hold down ESC and Fn and continue to tap F2.


You should not press and hold, you need to press it repeatedly until the BIOS shows up on the screen.

If that does not happen F2 is not the right key for your system (it depends on the maker and model of your computer).

  • If F2 doesn't work, try the Del key. Hit it repeatedly during power-up.
    – hmayag
    Jul 11, 2013 at 12:02
  • 1
    I am no novice and I did it tens of times(starting the BIOS or the boot menu). Since Grub 2.0 the BIOS doesn't want to load any more. F12 was for the boot menu and Del for BIOS, none work. I can press any button and it will still load GRUB. Oct 17, 2013 at 20:31
  • You are failing to think GRUB has anything to do with it, remove your hard disk from your computer (note, GRUB lives there) and you will get the same results... Oct 17, 2013 at 20:33

This is an old question, but it does not seem to have a fully working answer. Here's my try.

The cause of the problem is a combination of BIOS not having initialized the keyboard (along with other legacy USB devices) and GRUB being unable to use it properly.

The solution is:

  1. Unplug your boot drive completely;
  2. Try finding the most generic keyboard (in my case, I failed to proceed with a fancy multimedia keyboard, even when following this instruction). A standard 101/104-button keyboard would be the best; you need it only once;
  3. Try plugging in your keyboard directly to USB ports (unplug your USB hosts if any);
  4. Try different USB ports, preferably not USB3.0 (blue) ones;
  5. Press BIOS setup key (Del, F2, Esc or whatever your motherboard uses);
  6. In BIOS disable Fast Boot.

This will make your boot process slower, but GRUB will be able to see your USB keyboard.


This problem might be caused by the fact that one has acpi=off option in your grub.

To fix it:

  • change the GRUB_CMDLINE_LINUX_DEFAULT variable value from quiet splash acpi=off to quiet splash reboot=bios in your /etc/default/grub file

  • then please do sudo update-grub

Now you will be able to enter bios

However to make Ubuntu bootable again after you've change everything you needed in BIOS you should state quiet splash acpi=off in grub boot option (to enter it from GNU GRUB menu just navigate to your boot option (I guess it is Ubuntu) and press e)


I had this issue and fixed it accidentally. I restarted my computer and before letting anything happen, I held F2 , F10 and F12. Pretty sure one of them did the job, but I don't know which one.

I hope this works for you, too.


Every time you restart the computer without letting it rest, Grub will start up faster each time, overtaking the Bios start up menu.

You need to cause Grub to delay starting up. Discharging the computer worked a treat!

PC: Power off, unplug then hold the power button for 20 seconds to drain any remaining power. Plug it back in, power it back up and Grub will delay starting as if your computer has been switched off for weeks, so it won't completely overtake your BIOS menu. This will give you ample chance to access your BIOS menu. If you miss it, you'll need to unplug and discharge your computer again.

Laptops: Discharge by removing the battery and holding the power button for 20 seconds.


I am repeating the answer by Bruno Pereira because it was the secret.

DO NOT HOLD F2 but keep press & release F2.

By keep holding F2, Fn+F2, ESC+F2, etc, whenever HOLDING the keys, never went into the BIOS.


Try simultaneously keep pressing and release F2 button, if its not work then try F1 button if still not then try F8 or ESC its all about depends on your BIOS version. Mine is Bios - 3.1 - and key is F2.


When the start button press the continues press ESC button and pressing the F2 and Fn.

Then the BIOS is open.


Took me quite a while to got it. And it is very frustrating. On my end, I kept on hitting F2 (whatever key you need to press). Then the GRUB menu list shows up.

I hit C to go to console, then I type in reboot.

It will restart the system but this time, it will read the function key that you expect.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .