0

This was stupid of me, but now I can't fix it. I changed the name of /usr/lib to /usr/lib64 not realizing that the sudoers.so file was in this folder.

Now I can only log in in recovery and I have lost my sudo privileges (the computer cannot locate /usr/lib/sudo/sudoers.so) and I cannot rename the file back from lib64 to lib without sudo privileges.

Is there a work around to rename or copy this folder?

2

Run a Live USB or DVD with Ubuntu. From there you can rename it..

2

I had a similar problem. I did not use a Live CD, but here's what I did:

  1. Reboot the system and press Shift intermittently while Ubuntu started to load. That allows you to select the recovery mode, which takes you to a CLI with root privileges (thus you don't need sudo). Thats the second option in the list of boot options if I remember correctly.

  2. Then run

    mount-o remount,rw /
    

    to remount your hard drive as read/write (read-only by default).

  3. Rename your folder with

    mv /usr/lib64 /usr/lib
    

Your system should work fine after a regular reboot (issue the reboot command).

0

If your in recovery mode enable networking to get rw access on your hard drive. Drop into the root shell

mv /usr/lib65 /usr/lib

That should fix it.

  • "enable networking to get rw access on your hard drive" What? That does not make sense to me. And the remainder of this answer is already provided as an answer. – gertvdijk Jul 10 '13 at 20:54
  • 1
    enable networking option in safemode mounts the hard drive in rw mode. – Phil S. Jul 12 '13 at 18:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.