Logging into a server with ssh produces the landscape-generated message of the day, which includes the suggestion for using https://landscape.canonical.com/ to graph data:

  Graph this data and manage this system at https://landscape.canonical.com/

How can I trim this or other lines from the ssh greeting? With legal boilerplate added to the login banner already, I'd like to keep some information from landscape-sysinfo, but see less of it.

1 Answer 1


To remove the landscape.canonical.com line, create or edit (as root) the file /etc/landscape/client.conf.

In /etc/landscape/client.conf, add these lines:

exclude_sysinfo_plugins = LandscapeLink 

This works for all default plugins:

 Load, Disk, Memory, Temperature, Processes, LoggedInUsers, LandscapeLink, Network

So, to have your motd look more like this :

  System load:  0.83                Swap usage:          0%
  Usage of /:   59.5% of 117.38GB   Users logged in:     3
  Memory usage: 7%                  IP address for eth0:

...you would want to remove Temperature, LandscapeLink, Processes from the landscape-sysinfo process.

These can be added in the client.conf file as before, comma separated:

exclude_sysinfo_plugins = LandscapeLink,Temperature,Processes

This can be tested one the command line with:

landscape-sysinfo --exclude-sysinfo-plugins=Temperature,LandscapeLink,Processes

See landscape-sysinfo --help for some additional information.

  • 2
    /etc/landscape/client.conf should be owned by landscape user for settings to take effect. Confirmed here: bugs.launchpad.net/cloud-init/+bug/1066115
    – Ray Shan
    Dec 9, 2013 at 1:36
  • 1
    Not only does /etc/landscape/client.conf have be owned by user landscape, it should also belong to group landscape. sudo chown landscape:landscape /etc/landscape/client.conf did the trick.
    – Ciryon
    Nov 13, 2014 at 19:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .