10

I am beginner in Ubuntu 12.04, and have a problem with aircrack-ng. airodump-ng gived me a fixed channel -1 error. The access point is on channel 5, but I can't switch to that channel because of that error.

My hardware is: Broadcom BCM431, driver b43. I've tried patching, but had a problem with driver installation.

  • mmm What exactly do you need? – Mr.lalala Jul 10 '13 at 17:24
  • What is the problem? Did you get an error? – Lucio Jul 10 '13 at 18:11
  • @Lucio the problen is in the title but I have never seeen this with Ubuntu(nor did I find anything on it) but I do find this message related to backtrack(though the solutions I see that are for backtrack are not clear to me how they relate to Ubuntu). – Rinzwind Jul 10 '13 at 18:18
  • I don't understand your message. Are you saying that you get the same error than @Mr.lalala? – Lucio Jul 10 '13 at 18:26
  • Sir I use the option --ignore-negative-one in aireplay-ng it works but I am not getting WPA handshake to crack the WPA key please give solution for this – user294566 Jun 18 '14 at 6:14
12

Download and install the latest Aircrack-ng development (beta). There's an --ignore-negative-one switch that you can use to fix that fixed channel -1 annoying error.

Here's how you can install the latest Aircrack-ng.
Type the following commands in a terminal (Ctrl+Alt+T).

  1. sudo apt-get install subversion libnl-dev
  2. cd /opt/
  3. sudo svn co http://svn.aircrack-ng.org/trunk/ aircrack-ng
  4. cd aircrack-ng
  5. sudo make
  6. sudo make install

Once it's done, run aircrack-ng without any options, and look at the first line, it should read something like this:

Aircrack-ng 1.2 beta1 r2312 - (C) 2006-2013 Thomas d'Otreppe

Now, when you use airodump-ng and aireplay-ng, always use the option --ignore-negative-one.

| improve this answer | |
  • 2
    If sudo make gives errors you may also need to run sudo apt install libssl-dev libnl-3-dev libnl-genl-3-dev. See cseverson.com/docs/severson-wifi-hacking.pdf – NULL Jan 24 '17 at 21:04
  • @NULL I still get "pkg-config not found" / "Cannot find development files for any supported version of libnl" :( – Powerslave Dec 3 '17 at 22:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.