5

As I understand it, the oss-compat package is supposed to enable ALSA's OSS compatibility layer to create /dev/dsp files for your sound devices for compatibility with older applications. It's description states:

The purpose of this package is for applications that only support OSS
to depend on it, hence preventing common "/dev/dsp not found" errors
that would confuse unexperienced users.

Yet after installing it, no /dev/dsp devices have been added to the system and older applications still have the same problems. Other OSS emulation instructions also did not work.

I though it might have trouble as I have two sound devices (a sound card and tv/fm tuner), but physically removing one device and restarting made no difference.

I have also tried the aoss and padsp OSS wrapper applications but without success (works for applications not seeing /dev/mixer, but not those that require /dev/dsp).

1
  • 1
    Are the ALSA modules like snd-pcm-oss loaded?
    – CL.
    Jul 10, 2013 at 9:13

1 Answer 1

5

According to the comments on a bug filed on launchpad, it seems the oss-compat package works under the assumption that the ALSA OSS compatibility modules (snd-pcm-oss, snd-seq-oss and snd-mixer-oss) are already in your current installation. Unfortunately, it seems the Ubuntu kernel no longer includes these modules by default and it is necessary to recompile your kernel with a custom config to include them.

A simpler option (which is only available on newer Ubuntu versions) seems to be the osspd package that creates a daemon proxy for emulating OSS.

1
  • osspd(8) worked like a charm. You need to reboot your system beforehand though.
    – FUZxxl
    Apr 3, 2015 at 17:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .