1

I have two old hard drives from my MacBook that I would like to get usable files off of. The problem is I don't have permission to access the files unless I do gksudo nautilus, which means I can't really use it, and I can't organize it on my new ubuntu-based laptop. I would like to be able to just use these files normally.

I tried to go into the folder properties to see if I could change the permissions, but I got the following error message:

myname@mycomputersname:~$ gksudo nautilus Initializing nautilus-dropbox 1.4.0

**

ERROR:nautilus-properties-window.c:1836:schedule_owner_change_timeout: assertion failed: (NAUTILUS_IS_FILE (file))

Anyway, I would like to just remove the permissions from this drive if possible. There are other answers similar to this one but none deal with both mac drives and Ubuntu 13.04.

Update, I tried chmod and chown, neither worked and I got this message, repeated for every file in the drive.

chmod: changing permissions of ‘folder/filename.id’: Read-only file system failed to change mode of ‘folder/filename.id’ from 0644 (rw-r--r--) to 0777 (rwxrwxrwx)

  • I have the same issue here. Using root (gksu nautilus) I can add/remove files, but as my normal user it says the file system is read-only and won't let me do anything, not will it allow me to change the permissions on the mounted drive. This seemed to have happened after an update. – dtigue Aug 20 '13 at 23:03
1

This is a real cheat I picked up when I was new to Ubuntu and afraid of the command line - install dolphin, the KDE file manager. gksu dolphin to use it instead of Nautilus. You can copy files easily, but for your purpose, you can change file permissions or owners easily and recursively with a nice GUI interface. It's going to install a lot of KDE stuff you might not need otherwise, but it's a really nice file manager I use a lot.

I would copy everything off to a safe place using dolphin, change the file permissions and owner to something that makes sense, format the drives to ext4, and put them in an external USB housing. Bingo - you have the files, you can use the files, and you have a couple of USB drives as well.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.