When I reboot my computer, a black screen appeared with the following message:

could not write bytes: Broken pipe

* Stopping save kernel messages...                               [ok]
* Checking battery state...                                      [ok]
* Stopping system V run level compatibility...                   [ok] 

This is the third time I have reformatted my computer and reinstalled Xubuntu for the same error.

The following is the log file from "/var/log/lightdm/lightdm.log" when following @sameetandpotatoes' instructions found below:

[+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.00s] DEBUG: Starting Light Display Manager 1.2.3, UID=0 PID=1033
[+0.00s] DEBUG: Loaded configuration from /etc/lightdm/lightdm.conf
[+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.00s] DEBUG: Registered seat module xlocal
[+0.00s] DEBUG: Registered seat module xremote
[+0.00s] DEBUG: Adding default seat
[+0.00s] DEBUG: Starting seat
[+0.00s] DEBUG: Starting new display for greeter
[+0.00s] DEBUG: Starting local X display
[+0.00s] DEBUG: Using VT 7
[+0.00s] DEBUG: Activating VT 7
[+0.00s] DEBUG: Logging to /var/log/lightdm/x-0.log
[+0.02s] DEBUG: Writing X server authority to /var/run/lightdm/root/:0
[+0.02s] DEBUG: Launching X Server
[+0.02s] DEBUG: Launching process 1041: /usr/bin/X :0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+0.02s] DEBUG: Waiting for ready signal from X server :0
[+0.04s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.04s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+1.20s] DEBUG: Got signal 10 from process 1041
[+1.20s] DEBUG: Got signal from X server :0
[+1.20s] DEBUG: Connecting to XServer :0
[+1.20s] DEBUG: Starting greeter
[+1.20s] DEBUG: Started session 1051 with service 'lightdm', username 'lightdm'
[+1.52s] DEBUG: Session 1051 authentication complete with return value 0: Success
[+1.52s] DEBUG: Greeter authorized
[+1.52s] DEBUG: Logging to /var/log/lightdm/x-0-greeter.log
[+1.52s] DEBUG: Session 1051 running command /usr/lib/lightdm/lightdm-greeter-session /usr/sbin/lightdm-gtk-greeter
[+1.73s] DEBUG: Greeter closed communication channel
[+1.73s] DEBUG: Session 1051 exited with return value 1
[+1.73s] DEBUG: Greeter quit
[+1.73s] DEBUG: Failed to start greeter
[+1.73s] DEBUG: Stopping display
[+1.73s] DEBUG: Sending signal 15 to process 1041
[+1.76s] DEBUG: Process 1041 exited with return value 0
[+1.76s] DEBUG: X server stopped
[+1.76s] DEBUG: Removing X server authority /var/run/lightdm/root/:0
[+1.76s] DEBUG: Releasing VT 7
[+1.76s] DEBUG: Display server stopped
[+1.76s] DEBUG: Display stopped
[+1.76s] DEBUG: Stopping X local seat, failed to start a display
[+1.76s] DEBUG: Stopping seat
[+1.76s] DEBUG: Seat stopped
[+1.76s] DEBUG: Required seat has stopped
[+1.76s] DEBUG: Stopping display manager
[+1.76s] DEBUG: Display manager stopped
[+1.76s] DEBUG: Stopping daemon
[+1.77s] DEBUG: Exiting with return value 1

Press Ctrl + Alt + F2. You will then see a new screen that looks like a full screen terminal. Then, you can type in your username and password. If you would like to return to the GUI, try typing the following command:

sudo service lightdm start

You also may want to check to see if you are booting into text mode by default. To do that, use the following commands in Terminal:

sudo nano /etc/default/grub

Find this line:


If it says "text", please change it to "quiet splash".

If you made any changes, you need to update grub. You can do this with this command:

sudo update-grub

Reboot your computer and see if it works.

  • When I entered "sudo service lightdm start", the following appeared, but no GUI: * Starting the Winbind daemon winbind [ok] saned disabled; edit /etc/default/saned * Checking battery state... [ok] Thanks for the fast response! – Daniel Grothe Jul 9 '13 at 17:00
  • It now displays: "lightdm start/running, process 1470", but no GUI. – Daniel Grothe Jul 9 '13 at 17:12
  • Try these two: sudo startx, sudo gdm. – sameetandpotatoes Jul 9 '13 at 17:21
  • "sudo gdm" is an unrecognized command and "sudo startx" does not put me in my own account, nor can I change to it, nor run any apps. What do I do next? – Daniel Grothe Jul 9 '13 at 18:08
  • 1
    I tried "sudo service lightdm restart", instead of "...lightdm start", and now it worked. – Daniel Grothe Jul 10 '13 at 0:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.