I upgraded from 12.10 to 13.04 and my Virtualbox-4.1 stopped working. So I downloaded the Virtualbox-4.2 deb for Raring ringtail from their website and installed it. When I start Virtualbox, it starts fine. On trying to start a Virtual Machine I get this error.

RTR3InitEx failed with rc=-1912 (rc=-1912)

The VirtualBox kernel modules do not match this version of VirtualBox. The installation of VirtualBox was apparently not successful. Executing

'/etc/init.d/vboxdrv setup'

may correct this. Make sure that you do not mix the OSE version and the PUEL version of VirtualBox.

On running /etc/init.d/vboxdrv setup I get:

farhat@palantir:~$ /etc/init.d/vboxdrv setup
 * Stopping VirtualBox kernel modules                                           
 * Cannot unload module vboxdrv

What should be done here?



farhat@palantir$ sudo dpkg -l | grep -e virtualbox -e linux-headers -e dkms
ii  dkms                                                 all          Dynamic Kernel Module Support Framework
ii  linux-headers-3.8.0-26                    3.8.0-26.38                            all          Header files related to Linux kernel version 3.8.0
ii  linux-headers-3.8.0-26-generic            3.8.0-26.38                            amd64        Linux kernel headers for version 3.8.0 on 64 bit x86 SMP
ii  linux-headers-generic                                       amd64        Generic Linux kernel headers
rc  virtualbox-4.1                            4.1.26-84997~Ubuntu~precise            amd64        Oracle VM VirtualBox
ii  virtualbox-4.2                            4.2.16-86992~Ubuntu~raring             amd64        Oracle VM VirtualBox
  • Please, edit your question to include the output of dpkg -l | grep -e virtualbox -e linux-headers -e dkms. Jul 9, 2013 at 11:27
  • Did you reboot after purging virtualbox OSE edition?
    – Takkat
    Jul 9, 2013 at 11:39
  • added the output of dpkg and I didn't reboot after purging virtualbox-4.1
    – Farhat
    Jul 9, 2013 at 12:12
  • Tried rebooting as well. No change.
    – Farhat
    Jul 10, 2013 at 8:36
  • This answer helped me: askubuntu.com/questions/900794/… Nov 30, 2017 at 14:15

5 Answers 5


This command must run with root privileges. Try:

sudo /etc/init.d/vboxdrv setup

Also try purging everything:

apt-get purge virtualbox-4.1 virtualbox-4.2

then reboot, reinstall VirtualBox 4.2, and run:

sudo apt-get -f install

to install any missing dependencies.

Run sudo /etc/init.d/vboxdrv setup again to make sure the VirtualBox kernel module is installed.

  • I get the same message and VirtualBox still doesn't work even after running with sudo.
    – Farhat
    Jul 9, 2013 at 11:23
  • 4
    Please note that VirtualBox should NOT BE RUNNING when you run the vboxdrv script. Close the program and run the script with root privileges.
    – hmayag
    Jul 9, 2013 at 11:34
  • I had shut down Virtualbox while using the sudo /etc... command.
    – Farhat
    Jul 9, 2013 at 12:10
  • @Farhat answer updated. Jul 9, 2013 at 12:16
  • 2
    I followed the updated steps. Still getting the same error on running vboxdrv and Virtualbox gives the same error as before. Thanks for trying to help.
    – Farhat
    Jul 9, 2013 at 12:29

I might have a good hint on this one. I've had a 64 bit kernel on my 32 bit system for some funny reason. Nothing I did managed to avert this annoyance but once I reverted back to a 32 bit kernel all of a sudden everything popped back into place.


This is pretty old question, but I recently had similar issue with Virtual Box 5.0. Reinstalling Virtual Box using '.deb' from their website helped.


First you need to remove all Virtualbox-related Softwares/Dependencies by running this:

sudo apt-get  remove virtualbox

then reboot your OS and reinstall downloaded version.

It happens when you have an installed app with same name as one of Virtualbox dependencies has.

Hope it help.


Stolen from VirtualBox - RTR3InitEx failed with rc=-1912 (rc=-1912)

Credits go to @Ravexina https://askubuntu.com/users/264781/ravexina)

But it's the definite solution to the problem.

It seems that your installation version of virtualbox is for 32-bit architecture while you are running 64-bit operation system which can be the cause of this problem.

My workaround would be to remove the installed version from PPA, and installing virtualbox from official repositories.

To remove virtualbox, run:

sudo apt autoremove --purge virtualbox*

After that make sure there is no other version installed on your system by:

dpkg -l virtualbox* | grep ^i

You shouldn't get any output, also you can try to run virtualbox to make sure it's not installed.

Then remove all related PPAs from your sources.list and sources.list.d directory. ex:

mkdir ~/apt-tmp
sudo mv /etc/apt/sources.list.d/* ~/apt-tmp

Make sure there is nothing except official repositories sources in /etc/sources.list.

And update your sources:

sudo apt update

Now we can search to see which versions are available to install:

apt-cache madison virtualbox | grep -iv sources

Which produces an output like this:

virtualbox | 5.0.32-dfsg-0ubuntu1.16.04.2 | http://mirrors.kernel.org/ubuntu xenial-updates/multiverse amd64 Packages
virtualbox | 5.0.18-dfsg-2build1 | http://mirrors.kernel.org/ubuntu xenial/multiverse amd64 Packages

Then I would install the last version mentioned in xenial-updates:

sudo apt install virtualbox=5.0.32-dfsg-0ubuntu1.16.04.2

Also sudo apt install virtualbox, would be fine, but I would go with the above command to make sure my desired version is going to be installed.

And after all, check that the correct version is installed.

From command line:

dpkg -l virtualbox* | grep ^i

ii  virtualbox                     5.0.32-dfsg-0ubuntu1.16.04.2 amd64        x86 virtualization solution - base binaries
ii  virtualbox-dkms                5.0.32-dfsg-0ubuntu1.16.04.2 all          x86 virtualization solution - kernel module sources for dkms
ii  virtualbox-qt                  5.0.32-dfsg-0ubuntu1.16.04.2 amd64        x86 virtualization solution - Qt based user interface

From GUI: to make sure correct version is running.

Help menu -> about virtualbox

Not the answer you're looking for? Browse other questions tagged .