11

Building on a question from 2010 (3 years ago) I'm trying to achieve the exact opposite: I want to disable the Ctrl+Alt+ keyboard shortcut to kill the X server. For me, it appears to be disabled in System->Preferences->Keyboard but practically it's still up and running.

dontzap doesn't seem to be "active" (as in actively developed) either, and it seems counterintuitive to have to install it in order to disable this key-combo.

Any other ways to properly disable the shortcut?


PS: I think it's a bug.

PPS: Some time ago, I enabled it cuz I thought it was kinda cool - not knowing that it was a one-way street without a functioning / reliable option to disable it again.

6
echo $'Section "ServerFlags"\n  Option "DontZap" "yes"\nEndSection' | sudo tee /usr/share/X11/xorg.conf.d/dontzap.conf
2
  • Thanks - obviously the above answers are ancient as /etc/X11/xorg.conf hasn't been populated for ages now.... Sep 4 '17 at 14:36
  • xorg.conf is empty, but I just tried this on Ubuntu 18.04 and it seems to work.
    – Mike Nakis
    Dec 12 '19 at 15:07
4

Please edit the file /etc/X11/xorg.conf:

gksu gedit /etc/X11/xorg.conf

There should be a section in this file called "ServerFlags". If it's not there, add it as below at the end of the file. If it is there, make sure that the line Option "DontZap" "yes" is in there with yes as a parameter:

Section "ServerFlags"
Option "DontZap"  "yes"
EndSection
7
  • thx! followed your instructions (the file was empty previously). won't test it now, but on a fresh (re-)boot to see if it truly is disabled now... Jul 9 '13 at 13:01
  • ah right. you can also look here: askubuntu.com/questions/4662/…
    – January
    Jul 9 '13 at 13:13
  • /etc/X11/xorg.conf was empty. Bad ? Jul 9 '13 at 13:14
  • 1
    No, I only shows how old I am. yeah, X detects most of the settings automagically nowadays (and I sit on a 10.04 system which still has a proper xorg.conf).
    – January
    Jul 9 '13 at 13:15
  • So, did it work?
    – January
    Jul 9 '13 at 14:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.