10

I have just done a fresh install of 12.04.2 and found out that i could not ssh to this PC. I tried to install openssh-server but it said that "Package openssh-server is not available..." What is missing?

5

In the Ubuntu Software Center search for openssh-server or else open the terminal and type:

sudo apt-get install openssh-server

If that doesn't work, open the Ubuntu Software Center and browse to Edit -> Software Sources -> Ubuntu Software tab, and make sure that you have at least the main, universe and multiverse repositories marked with a check mark.

  • 5
    Yes I did that "sudo apt-get install openssh-server" before and it was saying the same. The problem was I was just doing a apt-get upgrade and not a update. After I did a update and ran the same command it worked. – Naten Baptista Jul 10 '13 at 10:39
3

Go to the Ubuntu Software Centre and browse to the Edit -> Software Sources -> Ubuntu Software tab. Then select Other -> Select Best Server under Download From.

Afterwards run in a terminal (Ctrl+Alt+T):

sudo apt-get update && sudo apt-get install openssh-server

Follow the on-screen instructions. This will resolve the issue.

1

I was following the advice to remove and re-install openssh-server via CLI, but got an error saying the package was not available.

Update apt-get then tried again with success.

So, the sequence that succeeded was:

sudo apt-get remove openssh-client openssh-server
sudo apt-get update
sudo apt-get install openssh-server
  • lol wtf removal of ssh client will break almost every packet in your system – scythargon May 21 '14 at 7:47
0

I had the same problem because in installed Ubuntu on a virtual machine, but i didn't connect it to internet because i used a private switch. I just changed the switch and connect it to internet with a private switch. After that i changed the sources code and chose one for my case (Germany). Now it working. You can try the same and i hope everything gonna for you too. (Don't forget to run the update)

Cheers

0

If all else fails you can find the package available for your distribution via the under-utilized Ubuntu Package Search

In your case it will be found here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.