1

Using LXLE (Lubuntu) 12.04 32-bit. Using Thunderbird and Firefox for main Web apps.

Whenever I click on a web link within a message in Thunderbird, it opens a new tab in Firefox, but always opens the page at this URL: "http://www.lxle.net/index.php?x=about".

This behavior doesn't change when running Firefox in Safe Mode. Firefox is not configured by me in any way to redirect to that LXLE main page, so it must be originating from within the distro OS.

Changing settings for the default web browser hasn't changed this behavior, either from the GUI "Preferred Applications" app, or from the command "sudo update-alternatives --config x-www-browser".

How to get the email-based links to open properly in Firefox?

migrated from unix.stackexchange.com Jul 8 '13 at 18:49

This question came from our site for users of Linux, FreeBSD and other Un*x-like operating systems.

  • Does Firefox in LXLE behave normally otherwise or do you see the "about LXLE" page each time you open Firefox? – user25656 Jun 15 '13 at 15:20
2

I've long had the same problem. After some research, I just found !

If you edit the file ~/.local/share/applications/mimeapps.list, you'll see the line below x-scheme-handler/https=yelp.desktop

Edit the file /usr/share/applications/yelp.desktop and you'll see this :

[Desktop Entry]
Version=1.0
Name=Help
Comment=Get help with Lubuntu
Exec=firefox http://www.lxle.net/index.php?x=about
Icon=help-browser
StartupNotify=true
Terminal=false
Type=Application
Categories=Utility;

Just change the URL by %u like this :

[Desktop Entry]
Version=1.0
Name=Help
Comment=Get help with Lubuntu
Exec=firefox %u
Icon=help-browser
StartupNotify=true
Terminal=false
Type=Application
Categories=Utility;

Save the file and did a test!

  • My problem was that every time I clicked on a link in Thunderbird, I was taken to the ubuntu-online-tour, no matter what the actual link was. This answer led me to look at .local/share/applications/mimeapps.list, which had many lines (both x-scheme-handler and application/x-extension) specifying that tour. I replaced that mimeapps.list file with one from another ubuntu machine (much shorter file, no mention of the tour) and now all is well. – Phil Hirschhorn Feb 9 '15 at 18:14
0

In LXLE look in system tools and find alternative configurator; that might be able to make the settings stick.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy