3

I have Xubuntu 13.04 on my desktop as a dual-boot system with XP. Installed it at first time two days ago and suddenly got this problem. Writing my question from good old trouble-proof Windows XP (long live Microsoft).

The problem:

Xubuntu boots to command line instead of GUI. It prompts for a login and a password and after I provide I get a command line instead of Xubuntu.

Mostly people suggest to type:

startx 

in command line. But is it suitable for Xubuntu? Xubuntu uses Xfce, not GNOME. What do I need to type to start GUI from command line?

Why does this happen? How can I start GUI again? And what can I do to avoid it next time?

  • Have you tried startx? What does it do? – mitchfish36 Jul 8 '13 at 14:51
  • No, I didn't. Please see my answer. – Green Jul 8 '13 at 21:13
2

So I managed to get GUI back without any command line typing. I did nothing, just hit Enter on Ubuntu option the next boot attempt. Just didn't let GRUB stopwatch to reach 0 and didn't use arrows in GRUB menu, just hit Enter. Very strange.

First of all, I remember when it happened. I turned on the computer and left my room to do other things. Before it I always manually selected in GRUB menu what system to load, either Xubuntu or Windows. I never let GRUB stopwatch to reach 0 and boot itself, I always hit Enter earlier. So when I came back to computer I saw the command line prompt instead of GUI.

I didn't know how to restart Xubuntu safely from the command line, so in this situation I just hit the restart button. The following boot I immediate used arrows in GRUB to go down the menu (up to Windows XP option) and then go up to select Ubuntu again. Just to stop GRUB stopwatch. Then hit Enter. But got command line again. I again reset the computer with the reset button.

This time I switched to Windows, surfed the Internet for answers, wrote this question. Found this 7 pages thread http://ubuntuforums.org/showthread.php?t=1570540. A user experienced the same problem in 2010. The main solution is on page six http://ubuntuforums.org/showthread.php?t=1570540&page=6&p=9935242#post9935242. So I did the same.

I tried to boot again but this time I didn't use arrows. I just immediately hit Enter on Ubuntu option in GRUB. And I got GUI. Xubuntu is installed but GRUB's option is Ubuntu, not Xubuntu.

Xubuntu also fixed some crash when I entered GUI:

execution path:
   usr/bin/Xorg
package:
   xserver-xorg-core 2:1, 13,3 - Oubuntu6
problem type:
   Crash
title
   Xorg crashed with SIGABRT in raise()

So my conclusion is: if you want Xubuntu, immediately hit Enter in GRUB menu. Don't let stopwatch to get 0 and don't use arrows. I you want Windows, choose a Windows option using arrows and hit Enter. Isn't it ridiculous?

  • Ah, yeah. Xorg crashed dropping you at a TTY. – Seth Jul 8 '13 at 21:08
  • I'm not sure I understand your answer. Did you get the GUI back on the next boot? – Seth Jul 8 '13 at 21:17
  • @Seth, Yes, I got GUI back. I did nothing at all in command line, didn't type any special commands. I just hit Enter on Ubuntu option in GRUB. I didn't let GRUB to automatically start Ubuntu. – Green Jul 9 '13 at 19:03
0

Try to enter the following command:

startxfce4  

startxfce4 - initialize an Xfce session

startxfce4 is a script responsible for starting an Xfce session. It runs xinit passing the file specified in the FILES subsection as an argument.

FILES

~/.config/xfce4/xinitrc 

User configuration file

/etc/X11/xdg/xfce4/xinitrc

System wide configuration file

  • Welcome to AskUbuntu! This may be better as a comment. You can expand your answer, if you feel you can explain why this would work. – No Time Feb 4 '15 at 20:11
  • @karel no I didn't actually. Not unless it's really bad 1st attempt. I upvoted it to 0 now – No Time Feb 5 '15 at 1:17

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.