This question already has an answer here:

I recently installed wireshark and before i could even start capturing anything it says "no interface can be used for capturing in this system with the current configuration"

as im new to wireshark, does anyone know how to change the current configuration and what to change them to? sorry for any duplication and for shortness in description but i cant proceed without this configuration being set right

marked as duplicate by Warren Hill, Radu Rădeanu, Jorge Castro, belacqua, Eric Carvalho Jul 9 '13 at 0:09

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


The default installation of Wireshark requires root privileges to run packet capturing. This is why I suggested below to run it as a privileged user. As @Warren Hill kindly pointed out this is not the recommended way to use Wireshark.

Please read How do I run WireShark, with root-privileges? and follow @Oli's answer on how to reconfigure Wireshark to be able to run as your own user.

To make the group membership changes effective (as stated in that answer) you'll need to log out or restart the system. If you do not want to do that right now for any reason, temporarily login might help. (You'll have to specify your password twice: once for sudo and once for login).

$ sudo login <your_user_name>
[sudo] password for <your_user_name>:
$ DISPLAY=:0.0 wireshark

Answer left below for reference:

Try to run Wireshark with root privileges:

pkexec wireshark

According to the Wireshark Wiki:

Running Wireshark (or any other network capture/analyzer, for that matter) on Linux needs root privileges. Therefore, you have to have root privileges when starting Wireshark, else you can't capture data. Please note that you don't have to login as root when starting your computer, you can use su(1) or sudo(8) for that purpose.

  • ok i ran the command and it says... (wireshark:3274): Gtk-WARNING **: cannot open display: is this normal or is there something wrong? – James Jul 8 '13 at 11:34
  • I've come around a workaround for this: pkexec bash -c "DISPLAY=:0.0 wireshark". Could you test if Wireshark can now be started? – lgarzo Jul 8 '13 at 12:22
  • This is not the recommended way. See duplicate question – Warren Hill Jul 8 '13 at 12:33
  • @WarrenHill thanks for the heads-up! I added your advice into the answer by explaining not to do as I suggested before. While the content still remains true, I understand one should reconfigure the package instead of hacking root to be able to run it. Thanks again! – lgarzo Jul 8 '13 at 13:34
  • ok im kind of confused here as ive just checked the answers now. Do i type in the above command? or is that a bad thing to try? – James Jul 8 '13 at 13:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.