1

I'm using Ubuntu 13.04 Gnome edition. I have a problem with my Arduino Duemilanove Board. Previously I was using kernel 3.9.2-030902-generic. After I installed kernel 3.10rc6 and I started my arduino IDE, I didn't see the serial port /dev/ttyusb0 as before.

That's important as that's what I use for uploading my code onto the board. Now all I see is /dev/ttyS0. I tried plugging my board in all the usb port but none of them helped in uploading via /dev/ttyS0. I don't know it's actually because of kernel 3.10 but previously everything was working fine.

Here are links for lsusb and dmesg command output, taken after plugging the board.

I did finally remove kernel 3.10 and made 3.9.2 default, but dmesg remains the same and shows some errors in the last lines. I've tried searching Google for solutions, but haven't had any luck.

  • did you have to post all of dmesg? next time try: #dmesg -c Then plug in the arduino. then run #dmesg – j0h Jul 15 '13 at 0:56
  • I mean i would love to help, but there is soooo much usb stuff in your linked dmesg file. – j0h Jul 15 '13 at 0:57
1

I know that the answer is too late, but late answer is better than none I had the same problem, and i found the answer on the following link (https://stackoverflow.com/questions/9544557/debian-device-descriptor-read-64-error-71)

The problem is mostly due to a hardware issue.

that's the linux error code documentation, too:

  -EPROTO (*, **)       a) bitstuff error
                        b) no response packet received within the
                           prescribed bus turn-around time
                        c) unknown USB error
  • Thanks I don't have the faulty device currently but only solution I had to use then was to replace the device cause I later found that the device had actually gone buggy. – meteors May 13 '14 at 17:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.