This question already has an answer here:

How to associate file types with Sublime Text 2? have downloaded Sublime Text 2. I've unpacked it in /opt/Sublime Text 2/ directory.

Now I want to open all .conf files with ST2. But I can't set this easily. Xubuntu doesn't offer ST2 in the list of Open With programs.

I do:

right-click on the fonts.conf >> Properties... >> Open With >> Other Application.

And an Open With window appears. And it doesn't have ST2 application.

How either to add ST2 to the Open With list or how to associate a file with ST2?


Similar questions and are not answered:

associate program to a file where program is not in list

How to associate file types with Sublime Text 2?

why are simple things getting hard in Ubuntu (Xubuntu)?

marked as duplicate by Eric Carvalho, Seth Jun 13 '16 at 3:19

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


Read this answer: How to associate file types with Wine in Nautilus.

You must create/edit a .desktop file located in ~/.local/share/applications/ or /usr/share/applications/

Locate the Exec= parameter and at the end of the line add %U - it will be replaced with the filename to be opened.

Also see Associating file types in Ubuntu 13.10.

  • You can add %f to the end of the line instead of %U. Example: Exec=ProgramName %f – James Nov 11 '13 at 2:00

This is what I've just tried:

  1. Go to /usr/share/applications or ~/.local/share/applications/
  2. Create a new file appName.desktop (appName is the name of the app you want to use)
  3. Copy content of any other *.desktop file (I used gedit.desktop)
  4. Update the content: Name = , Exec = , ..., with %U being the filename to be opened.
  5. Save it.
  6. Right click on the file you want to be opened with the appName
  7. Go to Properties/Open With and click on 'Show Other applications' 8 Your appName should be there, just select it.

I found this way. And without any command line typing, which is good.

  1. In "File Manager" right click on a file (e.g. file.conf) you want to be opened by Sublime Text 2 (or any other application).

  2. Choose "Properties". A window titled file.conf - Properties should appear.

  3. In its tab "General" click "Open With:" and then choose "Other Application...". A window titled Open With should appear.

  4. At the bottom of this window select "Use a custom command:" option and then "Browse...".

  5. Browse to the necessary executable, Sublime Text 2, for example.

The most important part now: before click Ok put the selected path into double quotes, e.g.:

"/opt/Sublime Text 2/sublime_text"

because otherwise it cannot accept the path .

  • 9
    I don't have the option user a custom command :( – vishal Aug 7 '13 at 20:10
  • 1
    "Use a custom command" was removed some time ago, I believe before GNOME 3.0. – Waldir Leoncio Oct 27 '15 at 20:03
  • I suspect the quotes are needed only because there's a space in the path. – Keith Thompson Jun 7 '16 at 19:55
  • 1
    Still not possible with ubuntu 17. Possible with ubuntu 7. – Magicsowon Jan 17 '18 at 18:29

This answer worked for me: Globally associate file type with certain application

  1. Download and install deb file for sublime text Eg: from https://www.sublimetext.com/3

  2. After installation Check that file sublime_text.desktop exists in /usr/share/applications/

  3. Fire terminal and type:

    $ sudo gedit ~/.local/share/applications/mimeapps.list Add the following lines at the end: [Default Applications]

    : (some existing association mappings)

    [Added Associations]

    : (some existing association mappings)


    Save and Exit.

This file overrides the /etc/gnome/defaults.list, so all file association goes in to mimeapps.list file.

  • It's an answer to a different question. Each time you want to add sublime as owner of a file extension, you have to re-do this hacking. The proper answer is to add a /usr/share/applications/*.desktop file, such that whenever you want to open a file with Sublime, it'll be an option in the open file dialog. – rektide Sep 23 '16 at 15:39

Not the answer you're looking for? Browse other questions tagged or ask your own question.