So I had Ubuntu 12.04, and all was well - except it froze occasionally. Monkeying around with the kernel made no difference, so I asked here (can't find my old question). Someone advised upgrading to 12.10, so I did it but it didn't boot.

All I get is a partial boot and a black screen. I managed to get into the GRUB, and messed about in recovery mode. If I go via recovery mode, I can get to a command line, but it freezes after a couple of minutes. I tried doing sudo apt-get update, tried uninstalling and reinstalling graphics drivers, tried the whole clean/dpkg repair/check file system, not going so well.

I boot off a USB now, which means I get a fresh system each time which sucks, can't boot graphically, and don't really know what I'm doing with the command line. Can anyone help me?

UPDATE AND MORE INFO: I used the boot repair program, it made no difference. It returned http://paste.ubuntu.com/5855376, so there might be some helpful info in there?

My computer is an Acer Aspire 5750, it has an Intel® Core™ i5-2430M CPU @ 2.40GHz × 4, and Intel HD graphics 3000. Not sure which graphics drivers I should be using, but I don't have Nvidia, which I understand was the cause of some similar trouble.

UPDATE THE SECOND: I've narrowed it down a bit more. It seems like an incomplete install of X11, according to my friend who is more knowledgeable about these things. cat /var/log/Xorg.0.log puts out http://paste.ubuntu.com/5861520/, which seems to basically say that it can't load intel, vesa, modesetting or fbdev (also some fonts are missing, but I doubt that's the problem).

I tried adding the x-updates repository and doing apt-get update and apt-get dist-upgrade (with and without -f and -m), but it appears to have made no difference whatsoever. On the advice of , I made /etc/X11/xorg.conf (which was missing before) and put in

Section "Device"
Identifier "intel"
Driver "intel"
Option "AccelMethod" "uxa"

but it changed nothing. Not sure what to do now.

1 Answer 1


FIXED! Apparently, X wasn't configured properly. After reinstalling X11, I tried Xorg -configure, but it kept talking about another X process running. I went and got the 3.7.7 kernel, rebooted, and got into low graphics mode. Was able to get it to configure from there. This whole process has been very educational, but I'm glad it's over.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.