2

This question already has an answer here:

When I start the Terminal I want it to start up like this john@john:~/Desktop$ blah blah blah without executing the command so I tried to do this sh -c "cd ~/Desktop;blah blah blah; exec bash" but it executed the command.

marked as duplicate by ændrük, Alvar, Eliah Kagan, Eric Carvalho, Kevin Bowen Jul 7 '13 at 2:26

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • how did you do it? post an answer yourself! – mnagel Jul 6 '13 at 8:47
  • 1
    There that's how i did it :D – Jester Jul 6 '13 at 15:13
  • What do you mean? – Jester Jul 6 '13 at 15:18
2

Okay i have found a way to do this, first you go to

Edit>Profile preferences>Title and Command

and in the 'Run a custom command instead of my shell' put this

sh -c "cd ~/Desktop; exec bash"

now open gpedit and type this script in:

#!/usr/bin/expect -f

spawn -noecho bash

expect "$ " 

send "put what ever you want here"

interact

exit

save that as a anything.sh

then chmod +x anything.sh

and run the anything.sh with Terminal and you're all done! :D

  • 1
    I hope this helps people out :D – Jester Jul 6 '13 at 15:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.