1

I used Startup Disk Creator to try and make a bootable USB ubuntu stick to install on my new ultrabook.

I had my 2TB backup USB drive attached, as I had just backed up everything on the flash drive.

I ran the Startup Disk Creator (as detailed here: http://www.ubuntu.com/download/desktop/create-a-usb-stick-on-ubuntu ). I selected the appropriate ISO (which was surprisingly also pre-selected), and I checked the "Device to Use" and confirmed that it was the correct drive (by name). I clicked "Erase" to clean the drive.

A few minutes went by, and I saw activity on my USB drive. I thought perhaps it was formatting instead of erasing. Then I noticed that my backup drive activity was churning...not a good sign.

Worst possible thing was true, the startup disc creator was erasing my 2TB backup drive.

I have been googling to see what to do, and what exactly "erase" does in Startup Disk Creator. I am currently running testdisk and doing a deep scan, as the quick scan did not show a partition with files.

What did I do wrong with the Startup Disk Creator? How could it erase a disc that wasn't selected in the "Devices" dropdown? What exactly did it DO when it erased, and is my data completely hosed or can I expect this long deep scan to bear fruit?

  • 1
    Hello Jim, Welcome to AskUbuntu. Excuse me please but what is the question here? "What did you wrong" or a "I need a workaround to bring your data back"? I think the answer to "what was wrong" is implied in the body of your question: Your first error was to let your backup's external hard drive (2TB) plugged in while you run a critical process. Or you probably choose by an error the wrong drive. Do you mind to tell us which kind of support are you expecting here in order to get the best for you? Thank you. – Geppettvs D'Constanzo Jul 5 '13 at 22:57
  • 1
    BTW: Based in my experience, you may succeed bringing the whole partition back if you first erase your current partition table. This way will allow testdisk to find whatever was deleted and restore it. See previous answers like this: askubuntu.com/a/33805/9598 for further support and erase your current partitioning just if you know what you are doing and AT YOUR OWN RISK. – Geppettvs D'Constanzo Jul 5 '13 at 22:59
  • Hi, thank you for your input. I really have three questions; first, is this a user error or a bug (since I observed the correct drive on the screen but the wrong drive was erased). Second, what exactly does the "erase" button in startup disk creator do (does it delete the partition table, does it format the disk...?), and what is my best route to trying to recover the partition table. – Jim Jul 5 '13 at 23:58
  • I'm still running testdisc's deep scan. I will look at the links you posted to prepare for what to do next if testdisc doesn't help. Thanks again! – Jim Jul 5 '13 at 23:59
  • 1
    When it is about USB drives is a bit easy to mix up the device's names. I have been in that situation a couple of times or so. But I can't say for sure what happened in your case. What I can say is that the Startup Disk Creator won't erase the wrong disk by itself, other than that chosen by the user. For your other questions I am afraid that the best way to get support in this site is to open a new question for each one in order to receive the proper support. This is not a "forum-like" site but a place where to find answers for specific questions. So I suggest you to open new questions. ===> – Geppettvs D'Constanzo Jul 6 '13 at 0:03
-3

How could it erase a disc that wasn't selected in the "Devices" dropdown?

It is a bug in 'startupdisk creator'. The list box in startup disk creator shows only the first usb device in the destination. But it selects the last device. So when you saw the destination you would have noticed your flash drive, but actually the 2TB hardisk was selected. This will be visible only when you scroll down or maximize the window.

What exactly did it do when it erased?

The program may have tried to erase or format the drive, but it couldn't do it due to some reasons and it managed to corrupt the data by deleting whatever was possible like partition-table and has left the data to an unrecoverable state. Or maybe it might have even formatted the disk and deleted the data and left something to show up in the drive properties.

Is my data completely hosed?

Your data is gone forever and there is nothing you can do to retrieve them with the same folder structure. But you can use the recovery software like potorec, scapel, foremost, recurva etc. to get pieces of your data. Some recovery software might also retrieve you the 100% of data. But still that wouldn't be what you expected.

can I expect this long deep scan to bear fruit?

If you are referring to the deep scan in testdisk, then the answer is no.

But there is one important thing that you should do first. Get an empty hardrive of 2TB or more and make a clone of the affected one using dd command. This does not recover you data, it helps to have a backup of the affected disk. Do every experiments that you want to do using the different recovery methods only on the cloned drive.

  • 3
    Could you support your claims with actual facts? Like bug reports or code reviews? – Braiam Sep 16 '13 at 19:10
  • 1
    If you need to share something that's too long form for the site consider using pastebin.com, and post the link here! – slm Sep 17 '13 at 2:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.