Okay so before anybody marks this as a possible duplicate or something along those lines let me say what ive worked on; I have used Bumblebee,Manually installed the drivers myself,tried a bunch of old drivers and new ones in hopes of something happening,re-installed drivers and bumblebee and done a re-installation of the OS and nothing...

Im dualbooting Ubuntu 13.04 next to Windows 7 (both are 64-bit) and the problem is that i cant seem to get my GPU running and i found that Ubuntu cant acces the gpu for some reason (this showed up while working with bumblebee in a terminal)...i have Intel HD Graphics (built in) and an Nvidia Geforce 310m (512mb)

These are my specs;

CPU; Intel Core i5 Ram; 4Gb (3.7 to be exact) HDD; 500gb (divided equaly in half for both Operating Systems) GPU; Nvidia Geforce 310m 512mb (as mentioned) Computer/Laptop; Toshiba Satellite E205

:) Help is apretiated

  • I also have Optimus and just got my Nvidia card working. Could you try disabling Optimus in your BIOS, and setting your computer to use only discreet graphics? That way, the nvidia kernel module will see the card and load at boot time. – Travis G. Jul 5 '13 at 21:06
  • I dont have that option in my laptops BIOS o_o – thelinuxdrive Jul 5 '13 at 21:19
  • Do you have Bumblebee installed now? – aXept Jul 10 '13 at 7:57
  • I do and have for a while now and still nothing :/ i cant even execute optirun... – thelinuxdrive Jul 16 '13 at 16:52
  • Could you edit your question and add the output of lspci -nnk | grep -i VGA -A1. Also, why do you think that your GPU don't work? – Braiam Aug 27 '13 at 21:39

i have the Samsung q330 and i have the same issue, i can resolved it with this.

Open synaptic and remove all nvidia drivers and nouveaun, like so:

sudo apt-get purge nvidia * nouvea* or sudo apt-get clean nvidia* nouvea*

Open terminal and install:

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo add-apt-repository ppa:bumblebee/stable
sudo apt-get update
sudo apt-get install linux-headers-generic nvidia-319
sudo apt-get install bumblebee virtualgl linux-headers-generic
sudo apt-get install mesa-utils
sudo reboot

And you can test with this command:

optirun glxgears -info

If all works out you can see something like this:

  • GL_RENDERER = GeForce 310M/PCIe/SSE2
  • GL_VERSION = 3.3.0 NVIDIA 325.15
  • GL_VENDOR = NVIDIA Corporation

its run some 3D graphics and say you fps. You can use too optimusrun glxspheres, and glxspeheres to test mxpixel/sec Good luck


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.