28

After installing Ubuntu 13.04 x64, I realised that my sound wasn't working (only headphone showed up in settings).

Following this guide, I manually added my Dell Studio 1740 audio hardware to:

 options snd-hda-intel model=dell-m6

Within etc/modprobe.d/alsa-base.conf.

Using the test speakers feature, I found that no sound was coming out of my right speaker (the one with the power and volume dials).

7
  • Please clarify your question. Did this modification fixed your problem? Added more problems? If your are dual booting with Windows, does the speaker work under Windows?
    – edwin
    Jul 5, 2013 at 19:21
  • The modification allowed me to move from no sound to sound. However I am still getting no sound from second speaker.
    – A T
    Jul 5, 2013 at 19:24
  • Hardware problem ? : Could be that just the cable is interrupted inside your notebook or the contacts ? Jul 15, 2013 at 17:15
  • So you're saying I should buy a new cable and try with that? - FYI: My speakers are Altec Lansing VS4121.
    – A T
    Jul 16, 2013 at 11:13
  • 1
    @AT - not too quickly ! have overseen, that you said, it works all under windows ? - if it is same under windows, then it is something with cable, plug - but at which location ? - be tender to your technics! Jul 16, 2013 at 21:43

5 Answers 5

34

Just watch an Alsamixer Tutorial.


...try going to alsamixer (type alsamixer in terminal).

alsamixer

I found many bars having their right channel lower than their left. (In this image you see only one bar). So I just lowered all their volumes to zero and back up again so they became even.

(Navigation in alsamixer is easy. Just use your arrow keys. Right and left to select the bar, up and down to lower/raise the volume).

Make sure your sound card is the one selected. Pressing F6 will show you a list for the available sound cards. Select yours! ...If you're not sure try them all. It's not dangerous ;)

...It's a bit odd that balance wasn't showing this difference in channels in the sound settings nor in pulse audio volume control. alsamixer did the trick however. Hope this helps.

4
  • Worked for me also after increaseing the last 2 columns, right speaker started working.
    – Adrian
    Apr 5, 2016 at 15:32
  • 2
    I had the same issue. Looks like a bug somewhere. Ubuntu 20.04 Mar 22, 2021 at 8:44
  • 1
    This is the solution for me, under Ubuntu 20.04. Alsamixer: pressing s to select the USB sound card, then restore the balance with q. The headphones (Kingston HyperX Cloud II) I'm currently using has an USB sound card, which provides two devices under the Sound settings: Digital Output (S/PDIF) - HyperX Virtual Surround and Analog Output - HyperX Virtual Surround. While the Sound Settings had the Balance controls, changing it did not effect anything. Neither did pavuctronrol help.
    – LietKynes
    May 24, 2021 at 10:11
  • I've found this occurs mainly after doing a system reboot from Windows into Ubuntu. When I do a total shutdown on Windows, then a cold boot into Ubuntu, I generally don't have this problem. When I do, usually alsamixer is my fix. Oct 17, 2021 at 16:25
20
+25

First open Sound settings:

Sound settings

Then in Output tab adjust the balance for left and right speakers:

Sound output

Also you can click on Test Sound button to test the volume for each speaker.

2
  • 3
    Thanks, but the Test Sound dialogue is how I confirmed that no audio was being outputted from my right speaker.
    – A T
    Jul 16, 2013 at 10:42
  • 1
    @AT Then most probably there is a hardware problem. Jul 16, 2013 at 10:51
2

Open Pulseaudio volume control, then under the Playback tab (first tab from the left) check each channel volume level and check if the channels' volume levels are locked between them (they have to be locked in order to keep the same volume level for the two channels -left and right-). As a side check, check the plug too. Sometimes a bad contact kills the sound of one of the channels.

2
  • Thanks, but that doesn't work. Additionally the speakers and jack work fine when used on my Windows partition.
    – A T
    Jul 15, 2013 at 12:06
  • He just has hardware problem with speakers. Jul 15, 2013 at 14:12
2

pavucontrol did the trick for me.

sudo apt-get install pavucontrol

I am using Ubuntu 14.04 on this hardware (Intel motherboard) https://hardwarerecs.stackexchange.com/questions/7624/i-love-my-raspberry-pi3b-as-a-workstation-but-what-is-the-next-step-better/7625#7625

(A $38/free shipping to US) for-real computer.

I thought it was hardware until running pavucontrol.

It showed that one channel was turned all the way down. As soon as I started moving one they moved together, and it now works great.

1
  • Not sure. Anyway, this was 4 years ago, had a different laptop for 3.5 years and got a new laptop yesterday. Not sure about this old Dell of mine.
    – A T
    Jun 29, 2017 at 5:37
0

I too faced this problem not just with one Linux OS but all of them.

I was using creative sound blaster 0106. I tried all that I could but failed.

I recollected earlier I had Yamaha sound card and when I changed from windows XP to 7 but it did not work and so I procured Creative which worked fine with Windows 7 Ultimate after downloading and installing drivers for Windows 7, so I thought why not go back to Yamaha sound card and give a try in Linux.

It works fine without any additional effort.

So the problem is with Sound card and not Linux.

In addition I would like to add I was very impressed by Windows 7 but using genuine free edition of Linux Mint Sarah is a big pleasure and it upgraded to to Serena like a song I have tried many Linux distributions like Ubuntu PC Linux Peppermint and liked all of them and now settled with Linux Mint Serena. Hats off to Linux creators

2
  • 2
    Can you please edit this so that it's not just a wall of text?
    – Mithical
    Feb 16, 2017 at 11:18
  • 1
    Better have a look at the sound card for sound problems Try a different sound card Feb 18, 2017 at 2:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.