I am trying to install Ubuntu on an Acer Aspire 5320 laptop that was abandonded by a friend when he purchased a new machine. I have created several different Live USB drives using my primary Ubuntu computer and both Startup Disk Creator and Unetbootin. I have verified that these disks are all bootable using a third computer, a Gateway that is currently running Linux Mint. The problem is that every time I put one of these into the Acer I get a black screen with a two word message: Boot Error. I have entered the CMOS and ensured that the USB is the first boot option, so the error is being thrown in relation to the USB. I have since taken the situation from bad to worse. The Acer was running Windows Vista. The Windows installation worked but was hopelessly slow. I was able to boot into Vista and access the USB from inside Windows. It gave me the option of booting to the USB now ( which I knew would throw the aforementioned boot error ) or creating a boot helper on the hard drive. I opted for creating the boot helper. This ran to about 70% when it threw an error because there was no more space on the hard drive ( I know, I'm an idiot for not checking. My friend had literally crammed her entire hard drive with photos and videos. ). The result of this being that apparently just enough of the boot helper made it's way onto the hard drive that now when I try to boot to the hard drive I get absolutely nothing. Just a black screen with a cursor. I can no longer get into Windows, and I cannot boot to the USB. I appear to be completely stuck. I saw one similar question on here and the suggestion was to go into the BIOS and reset the USB Mass Storage option, but that is not an option in the CMOS on this Acer. The CMOS is extremely limited. Any help would be greatly appreciated.

1 Answer 1


You can fix boot problems with Windows using it's Repair CD or installation media. But before this I recommend you free some space on hard drive. There are several ways of doing this. You can use aforementioned Windows tools, but it is much easier to run Ubuntu LiveCD because it looks like much more normal system. Be sure that you chose right version of CD's architecture, I suspict you made 64-bit USB stick while your laptop has 32-bit Intel Celeron processor.

And if this does not help, you can extract hard drive from laptop and try to repair it on another computer.

  • I have no Windows repair CD. I have tried both 32 and 64 bit Live USBs with no success. It simply will NOT boot to a USB. It has to be something in the BIOS but the CMOS is so limited that I can't find anything that could be affected it.
    – Blind Fish
    Jul 5, 2013 at 2:55
  • 1
    Then you have to burn a CD and boot from it.
    – Danatela
    Jul 5, 2013 at 6:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.