So far I have tried downloading Steam and even Tux Racer, and nothing will run. It seems like it's a driver issue. I ran lspci -v in the terminal, and this is what popped up for my graphics card:

01:05.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RS880M [Mobility Radeon HD 4100] (prog-if 00 [VGA controller])
    Subsystem: Toshiba America Info Systems Device ff80
    Flags: bus master, fast devsel, latency 0, IRQ 18
    Memory at d0000000 (32-bit, prefetchable) [size=256M]
    I/O ports at 9000 [size=256]
    Memory at cfdf0000 (32-bit, non-prefetchable) [size=64K]
    Memory at cfe00000 (32-bit, non-prefetchable) [size=1M]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: <access denied>
    Kernel driver in use: radeon

You are using the free radeon-driver for your graphics, which has a bad 3d performance, therefor the games are not running, you need to install the fglrx-driver to play 3d-games. Take a look at:


| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.