0

In 'sudo gedit' I can not use Ctrl Space to activate fcitx input method.

I can activate fcitx with Ctrl Space as normal user.

I use ubuntu12.04.2 amd64 arch.

How to do with it ?

Thanks

2
  • Is gksudo gedit broken as well? (explained)
    – ignis
    Jul 4, 2013 at 15:22
  • I can run gksudo gedit successfully, but can not activate fcitx in it. Jul 5, 2013 at 4:21

1 Answer 1

4

Check: https://fcitx-im.org/wiki/FAQ#Root_application_under_normal_user_X

Root application in general cannot communicate with user application by user session dbus, but xim only has the restriction of things need to be run under same X.

BTW, X application is in general broken with sudo, it's highly recommended not to do that.

3
  • Good answer (upvoted it), but your last comment is outdated, please read askubuntu.com/questions/284306/… Jul 4, 2013 at 15:30
  • What I mean broken, is not ubuntu specific nor from the point of view that either su, sudo is used. DBus is so widely used, and see my reply before, no matter you're using sudo/su/etc, application cannot connect to user dbus, which mean quite a lot function is not working. For example, if you're using media player, and use mpris(a user session dbus protocol) to control this player, if thsi media player is running as root user, your controller will not be able to control it. And your root application will not find gnome-settings-daemon, and similar things will happen to many app.
    – csslayer
    Jul 4, 2013 at 20:35
  • Hahaha...Linux community now tends to explain its deficit as some philosophy.
    – funicorn
    Dec 25, 2017 at 15:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.