6

When I (try to) run uget in Ubuntu 13.04 I get this error:

user-pc:~$ uget-gtk                                                                                                                                                          
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.                                                              
Segmentation fault (core dumped) 

How can I solve this problem?

2
  • What version of uGet are you using? Jul 4, 2013 at 4:17
  • the most recent in repository. Jul 4, 2013 at 15:06

4 Answers 4

9

If you still have Segmentation fault (core dumped) message when trying to start uGet, a quick fix is

backup and delete uGet folder in .config/uGet. Then restart uGet

and it will be working again. Most likely issue is with DownloadList.xml (for some reason a error there dump uget core). However by doing so You will lose all your categories, settings and list of downloaded files.

1
  • Yes it worked on me on Ubuntu 12.04 uget 1.10.3 32 bit. Thank you. Feb 9, 2015 at 18:19
1

The problem is you are using the Ubuntu repository...and for some reason Canonical refuses to update the app there.

Ubuntu Software Center has version 1.8.2 which is not even compatible with Ubuntu 12.04 or newer.

The latest version of uGet is 1.10.3 and is available from http://uGetdm.com/downloads

A PPA is also available from that page.

4
  • the waning is gone but 'Segmentation fault (core dumped)' is not solved after the upgrade! Jul 5, 2013 at 2:19
  • 1
    I'm sorry for the late reply...I only check this site when I have time to...in the future please post on the uGet Forum - ugetdm.com/forum - in fact please go there and post about this issue preferably include what error you are getting now. Sep 7, 2013 at 8:01
  • @MinimusHeximus: don't upgrade it. Just rename the .config/uGet into anything. Or just run your uGet as another user. Try that. Feb 9, 2015 at 18:20
  • @MinimusHeximus actually yes, do upgrade because using unsupported version is not suggested. You should do the config as well but you should certainly upgrade as well. 1.10.4 is the current stable build. - Ade Malsasa Akbar don't tell people not to upgrade. Feb 13, 2015 at 18:39
0

I had segmentation fault error for version 2.0.8 and the problem was changing the download mode to aria2+curl in the setting but not having aria2 installed!

After installing aria2 it's working again.

sudo apt install aria2

4
  • that is due to enabling a plugin prior to installing it. May ask why you wanted to use the aria2 plugin? Dec 31, 2017 at 19:59
  • For multi-thread downloading. And there should be a check for aria2 installation status before letting people choosing it!
    – sajjadG
    Dec 31, 2017 at 20:28
  • or I could update the official website to explain this as a common problem. It is somewhat difficult to provide a checker since we support so many platforms and there would be so many different ways of checking. Jan 3, 2018 at 15:36
  • side note, aria2 is not needed for multi-connection downloading, this is already available in the Curl engine. Jan 3, 2018 at 15:37
0

delete home/user/.config/uget/ folder and reinstall aria2 solves the problem to me running kubuntu 18.04 bionic beaver

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.