5

Whenever I start Tor in Ubuntu 13.04, the Vidalia Control Panel opens, loads up and displays a status of "Connected to the Tor network!". However, the tor-infused firefox, does not pop up like it should.

Tor log:

jul. 04 02:09:11.859 [Notice] Tor v0.2.3.25 (git-17c24b3118224d65) running on Linux.
jul. 04 02:09:11.860 [Notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
jul. 04 02:09:11.861 [Notice] Read configuration file "/home/joren/.tor-browser/App/../Data/Tor/torrc".
jul. 04 02:09:11.872 [Notice] Initialized libevent version 2.0.21-stable using method epoll (with changelist). Good.
jul. 04 02:09:11.873 [Notice] Opening Socks listener on 127.0.0.1:9150
jul. 04 02:09:11.873 [Notice] Opening Control listener on 127.0.0.1:9151
jul. 04 02:09:11.937 [Notice] Parsing GEOIP file ./Data/Tor/geoip.
jul. 04 02:09:12.178 [Notice] No AES engine found; using AES_* functions.
jul. 04 02:09:12.178 [Notice] This OpenSSL has a good implementation of counter mode; using it.
jul. 04 02:09:12.235 [Notice] OpenSSL OpenSSL 1.0.0k 5 Feb 2013 looks like version 0.9.8m or later; I will try SSL_OP to enable renegotiation
jul. 04 02:09:12.740 [Notice] Reloaded microdescriptor cache.  Found 8497 descriptors.
jul. 04 02:09:12.740 [Notice] I learned some more directory information, but not enough to build a circuit: We have no usable consensus.
jul. 04 02:09:13.758 [Notice] Bootstrapped 5%: Connecting to directory server.
jul. 04 02:09:13.761 [Notice] Heartbeat: Tor's uptime is 0:00 hours, with 1 circuits open. I've sent 0 kB and received 0 kB.
jul. 04 02:09:13.908 [Notice] Bootstrapped 10%: Finishing handshake with directory server.
jul. 04 02:09:14.252 [Notice] Bootstrapped 15%: Establishing an encrypted directory connection.
jul. 04 02:09:14.507 [Notice] Bootstrapped 20%: Asking for networkstatus consensus.
jul. 04 02:09:14.615 [Notice] Bootstrapped 25%: Loading networkstatus consensus.
jul. 04 02:09:16.446 [Notice] We'd like to launch a circuit to handle a connection, but we already have 32 general-purpose client circuits pending. Waiting until some finish.
jul. 04 02:09:16.447 [Notice] Bootstrapped 45%: Asking for relay descriptors.
jul. 04 02:09:16.448 [Notice] I learned some more directory information, but not enough to build a circuit: We have only 113/3851 usable microdescriptors.
jul. 04 02:09:17.755 [Notice] We now have enough directory information to build circuits.
jul. 04 02:09:17.755 [Notice] Bootstrapped 80%: Connecting to the Tor network.
jul. 04 02:09:17.810 [Notice] Bootstrapped 85%: Finishing handshake with first hop.
jul. 04 02:09:17.818 [Notice] Bootstrapped 90%: Establishing a Tor circuit.
jul. 04 02:09:18.156 [Notice] Tor has successfully opened a circuit. Looks like client functionality is working.
jul. 04 02:09:18.157 [Notice] Bootstrapped 100%: Done.

How do I proceed solving this issue?

  • Have you tried stopping Tor and restarting it (without closing the Vidalia program)? I believe that this is a known bug, but this workaround seems to work for me. – sameetandpotatoes Jul 4 '13 at 0:25
  • Yes, I have tried that and it doesn't seem to work. Thank you for your reply. – Joren Jul 4 '13 at 0:28
5

Install Tor Browser in Ubuntu 16.04 and later

Tor Browser (torbrowser-launcher) is available in the default Ubuntu repositories in Ubuntu 16.04 and later. torbrowser-launcher handles downloading the most recent version of Tor Browser Bundle for you, in your language and for your architecture. After installing Tor Browser, it can be launched by searching for tor in the Dash and clicking the Tor Browser icon. The Tor Browser Launcher Settings app is also installed along with Tor Browser.

IMG:

  1. Update the gpg key:

    gpg --homedir "$HOME/.local/share/torbrowser/gnupg_homedir/" --refresh-keys --keyserver pgp.mit.edu  
    
  2. Tor Browser still may not launch after updating the gpg key due to being unable to update the Tor Browser version in:

    /home/your-username/.local/share/torbrowser/tbb/x86_64/tor-browser_en-US/Browser/TorBrowser/Docs/sources/versions

    Replace your-username with your username and replace en-US with your language in the following commands and run these commands:

    cd     
    mkdir sources  
    cd sources     
    touch versions    
    gedit /home/your-username/.local/share/torbrowser/tbb/x86_64/tor-browser_en-US/Browser/TorBrowser/Docs/sources/versions
    
  3. A Gedit window will open up. Copy the string TORBROWSER_VERSION=7.5 into the Gedit window and save the file.

  4. Launch Tor Browser for the first time.

    torbrowser-launcher 
    

Now Tor Browser will launch normally by clicking its icon. If an update to Tor Browser is available, the update will be installed as usual.

enter image description here


15.10 and earlier

Download the Tor Browser Bundle from the Tor Project Download webpage. Choose the version of the Tor Browser Bundle, either 32-bit or 64-bit, that matches your system.

Put the Tor Browser bundle file that you downloaded anywhere in your own user's directory (/home/your-username/) or in one of its subdirectories, and extract it using either of these two commands: unp FILE.tar.gz or tar -xzvf FILE.tar.gz where for FILE.tar.gz you substitute the name of the Tor Browser Bundle .tar.gz file that you downloaded.

Open the directory where you extracted the Tor Browser Bundle, and find the file called start-tor-browser. Right-click start-tor-browser and select Properties to open the Properties window. On the Properties window under the Permissions tab put a check mark next to Allow executing file as a program. Now you can start Tor in its own Firefox browser from the terminal by changing directory to the directory where you put start-tor-browser and then starting it like this:

cd /path/to/directory/where/you/put/start-tor-browser/
./start-tor-browser  
  • I have used the software center to download tor. Maybe i could try it this way. – Joren Jul 4 '13 at 13:22
  • 1
    Now I understand what happened. You didn't download the Tor Browser Bundle. Download the Tor Browser Bundle from the Tor Project Download webpage. Choose the version of the Tor Browser Bundle, either 32-bit or 64-bit, that matches your system. – karel Jul 4 '13 at 14:02
  • Just a complement: if you do what karel said and you can't open start-tor-browser, it is possible that Files/Nautilus is configured to NOT run exec txt files. To change this, go to Files->Preferences->Behaviors and change the Executable Text Files settings. – user175126 Jul 14 '13 at 17:27
  • @user175126: Actually it's Edit->Preferences->Behaviors in Nautilus, and it's not necessary to change the global settings for Executable Text Files in Nautilus. You can use chmod +x to change the permissions of an individual file to allow executing the file as a program. – karel Jul 14 '13 at 19:05
0

Use the vidalia interface to see the logs generated when you try to start Tor. It needs that exits a directory call: /var/run/tor, and your non root user must be the owner, the authorizations shall be 700.

And the time zone and hour must be correctly configured for your region.

protected by Community May 26 '15 at 11:08

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.