I am a new Ubuntu user and I don't have much knowledge about Linux.

I recently installed Ubuntu 13.04 x64 in my Samsung SF310 laptop. Everything works fine except for wireless adapter.

I have been looking around for solutions and I must have tried everything I found, but with no success.

I can tell you that I have a Broadcom 4313 [14e4:4727] (rev 01) adapter. If you need/want more info on my system, tell me how to get it and I'll post it here. I have tried this with no success as well as virtually all other posts here.

If anyone could please help me and give me some pointers, that would be great.

Output of rfkill list all:

0: samsung-wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: samsung-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

Output of lspci:

02:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)

Output of lshw:

*-network UNCLAIMED     
       description: Network controller
       product: BCM4313 802.11b/g/n Wireless LAN Controller
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:f4c00000-f4c03fff

I'm getting really frustrated... It's been 3 days trying to figure this out without getting anywhere... Everytime I try a new version of Ubuntu (or any other distro for that matter), I always have some kind of problem... :(

  • @karel I don't really think it's a dupe. I have tried those instructions as well, but to no avail. Furthermore, according to that same question, there is actually a bug being tracked for my adapter/kernel combo. The weird part is, that before I installed Ubuntu 13.04, I had Lubuntu 12.10 installed and had the same issues - but for some reason the same solution I used before doesn't work.
    – Joum
    Jul 4, 2013 at 7:35
  • umm.. if it's a new bug you should report it. Maybe tag it as regression describing when it worked (if used any workaround) and when it didn't (even with the workaround).
    – Braiam
    Oct 28, 2013 at 1:13

5 Answers 5


This is a known bug, with a lot of duplicates.

I followed robamlers advice, and downgraded the driver to the previous version. It worked, at least for me.


  1. Remove bcmwl-kernel-source version 6.20

    sudo apt-get purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-source

  2. I rebooted, just to make sure nothing remaining of the old driver. Not sure if this is necessary.

  3. Download and install bcmwl-kernel-source_5.100.82.112+bdcom-0ubuntu3_amd64.deb from http://packages.ubuntu.com/quantal/amd64/bcmwl-kernel-source/download

  4. UPDATE: Ignore updates to bcmwl-kernel-source_6.20.155.1 untitl a new version comes available by writing:

    Package: bcmwl-kernel-source
    Pin: version
    Pin-Priority: -1

to /etc/apt/preferences. (Courtesy of this answer)

More news: Upgrading to Ubuntu 13.10 Saucy Salamander will get you a warning about the 5.100 package, but the wireless interface still works quite fine.

Update: Now that bcmwl-kernel-source_6.30.223.141 is available, you can switch to the new driver.

  1. Remove pinning entry from /etc/apt/preferences

  2. Remove driver 5.100 version.

    sudo apt-get purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-source

  3. Install latest version from 'Software Center' -> 'Software Sources' -> 'Additional Drivers'.

  • Although I did not test this solution, I marked it as the correct answer as it seems to provide enough detail to explain how to rollback the driver to a previous version in case you are using 13.04.
    – Joum
    Sep 16, 2013 at 14:28
  • I tested it, it works fine!
    – Jazz
    Oct 13, 2013 at 12:25
  • On Mint 17 (based on Ubuntu 14.04), I didn't have the bcmwl-kernel-source package, installing it pulled the latest version which is working like a champ!
    – Bryan
    Jun 16, 2014 at 3:19
  • Quantal repos are deleted, someone knows where can I download old package?
    – ssoto
    Aug 9, 2014 at 10:35

Ubuntu 13.04 is using a linux 3.8 kernel, so your wireless modul might fail to build. This is a know issue, (Bug Report).

Please follow these instructions:

  • Download this file (The amd64 for your 64 bit system)
  • run dpkg -i ~/Downloads/bcmwl-kernel-source_6.20.155.1+bdcom-0ubuntu6_amd64.deb
  • sudo modprobe wl

This answer is credited to Glutanimate in this question.

  • Thank you for adding other options to this question. I don't plan to change anything in my current setup anytime soon, because I don't want to break it. It's working, and that is all I need right now. Maybe I'll come back to this later, +1'd!
    – Joum
    Sep 16, 2013 at 9:08

I have noticed that I got the popular question badge for this question which must mean that I am definetely not the only one having these issues.

Don't know if this helps someone else, but for me the solution was to let go of the 13.04 release and I started using the 12.04 LTS x64. The wifi adapter works flawless everywhere I try it. And the best part is it works out of the box. It worked during the live desktop booting from USB and it continued working after I installed Ubuntu in the HD.

In my limited knowledge, and the way I figure it, it must relate to the version of the driver being used in 12.04 LTS x64. For some reason, the version that comes with 13.04 (don't know about 13.10, haven't tried it), does not work as it is supposed to.

Hope this helps someone, even if only getting the required info to rollback the driver to a stable point in future releases.

  • 1
    The answer is nice, but opinions don't really fit into this site that tries to be objective and they doesn't answer this question. I will remove them, feel free to edit then back if you want. Sep 16, 2013 at 9:19
  • I tend to agree... The rant wasn't useful at all, gj!
    – Joum
    Sep 16, 2013 at 9:37

Try uninstalling this package bcmwl-kernel-source via sudo apt-get remove bcmwl-kernel-source and running this command in the terminal sudo modprobe brcmsmac.

  • tried it already, didn`t work
    – Joum
    Jul 4, 2013 at 15:35

I too have a Broadcom 4313 [14e4:4727] (rev 01) adapter. In our house we have three different wifi networks, all with WPA/WPA2 encryption. In Ubuntu 13.04 I had no problems with the wifi, I could use any of the networks.

But when I upgraded Ubuntu to 13.10 I could only use two of the three networks. I could still connect to the third network, and the DHCP info would be transferred, but I could not send any user data on that network. For instance: pinging the router would not result in any return packets.

Downgrading bcmwl-kernel-source fixed my problem.

A tip: When I downgraded the driver I had to remove a blacklist in /etc/modprobe.d: cd /etc/modprobe.d sudo mv blacklist-bcm43.conf ..

Not the answer you're looking for? Browse other questions tagged .