1

I've been having slow boot up times with a fresh install of 12.04.2 LTS. I see this in my syslog:

Jul  2 13:42:56 victor-Lenovo-U310 kernel: [20058.135895] ata1: link is slow to respond, please be patient (ready=0)
Jul  2 13:43:25 victor-Lenovo-U310 kernel: [20087.780435] ata1: COMRESET failed (errno=-16)
Jul  2 13:43:30 victor-Lenovo-U310 kernel: [20092.806429] ata1: COMRESET failed (errno=-16)
Jul  2 13:43:30 victor-Lenovo-U310 kernel: [20092.806436] ata1: reset failed, giving up

I tried the the following kernel parameters with no success:

libata.force=nohrst libata.force=nosrst libata.force=norst libata.force=noncq

I have tried re-installing 12.04.2 LTS and have also installed 13.03 and still nothing has worked. Also set the ATA controller to Compatible (IDE), AHCI, and RAID, and none of those fixed the problem. Reset my BIOS to factory settings, also nothing.

My specs:

  • Model: Lenovo IdeaPad U310
  • Processor: 1.7 GHz (2.6 GHz max turbo) Intel Core i5 3317U
  • RAM: 4GB (DDR3)
  • Graphics: Intel HD Graphics 4000
  • Storage: 500GB (5,400 RPM) HDD + 24 GB SSD (Can't use it for some reason)
5
  • Is that a new machine? Otherwise that's either a failing harddrive or a kernel bug. Leave your controller in AHCI mode.
    – ppetraki
    Jul 3, 2013 at 20:31
  • It's a fairly new machine, bought it in May of this year. It can't be a hard drive failure. It could be a kernel but bug. I'm using kernel version 3.2.0-48, but I get the same message with 3.5.x and 3.8.x. Jul 3, 2013 at 22:47
  • What I'm trying to determine is was that a fresh install or something that degraded over time? Those SSD accelerators can be a pain, it's worthwhile to disable it in BIOS. I can't tell from the logs which device is resetting, the SATA disk or the micro SSD? I'm sorry to say but SATA drives can just up and die, it's what they do. Please update your post with the additional logs.
    – ppetraki
    Jul 4, 2013 at 12:12
  • @ppetraki what other logs would you need? PS. I've tried disabling the SSD in BIOS, but I can't. Jul 5, 2013 at 1:20
  • From the sounds of it this might be your problem. askubuntu.com/questions/164423/… . Be careful managing that SSD. As for logs, seeing everything related to ata would be good, not just the last couple lines.
    – ppetraki
    Jul 5, 2013 at 12:09

2 Answers 2

2

found : libata.force=noncq but this add-in commandline isn't complete

added by changing:

GRUB_CMDLINE_LINUX="libata.force=16.00:noncq" 

in /etc/default/grub. after exit-save

update-grub

found also :

libata.force=8.00:noncq 
tried libata.force=16.00:noncq

for dmesg shows

>> ata3: SATA max UDMA/133 port i16@0xbc00 bmdma 0xcc00 irq 11 
>> ata4: SATA max UDMA/133 port i16@0xc000 bmdma 0xcc08 irq 11    
>> ata5: PATA max UDMA/133 port i16@0xc400 bmdma 0xcc10 irq 11

doesn't resolve

>>>ata5: SATA max UDMA/133 port i16@0xbc00 bmdma 0xcc00 irq 11
>>>ata5: link is slow to respond, please be patient (ready=0
>>>ata5: COMRESET failed (errno=-16)

hmm

ok, solved it.. but this makes it outside the situation you guys/girls have i removed a Promise ATA card (133/TX3) and mounted the boot-disk at onboard port. That made the SATA work - sigh.. knew it.. it was something simple..

1
0

I was getting same error. Remove the hard disk then connect your hard disk externally to the laptop or another pc, and format it. Reconnect it to the PC on which you want to install Ubuntu and then try to boot from flash drive or DVD.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.