When importing a library (cdms2) in python, I get the following error message:

ImportError: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.16' not found (required by /usr/local/uvcdat/1.3.1/Externals/lib/libcurl.so.4)

My version of libc6 is currently 2.15 (Ubuntu 12.04). My understanding is that the newest version is not in a stable repository: how can I force apt to update to version 2.16?

2 Answers 2


There is a much safer way to run a single app. Problem is: while glibc is meant to be backwards-compatible, it is not 100% accurate. Issues are known. So, do not update the library system-wide. Instead, prepare a whole set of updated libraries. Put them in, say, /catbed. Then just run

   /catbed/ld-linux.so.3 --library-path=/catbed:/whatever-else /usr/bin/python -python-args

Of cause, adapt the filenames to your case. This is much safer way to go, because if you mess up your system ld-linux+libc pair you will not be able to fix it from inside the OS. You will have hard times even chrooting into it then. I routinely use the trick for old proprietary Linuxes (gcc 3.1, kernel 2.3) on which I want to run Qt5.


Was the UVCDAT installation manually built one or downloaded the pre-built binaries ?

Binaries of UVCDAT 1.3.1 were built on Ubuntu 13.04 platform . Even if you solve this one, could come across many other errors. Try downloading UVCDAT 1.2. If you want the latest UVCDAT and want to stick to 12.04 try building from the source code. Else upgrade OS to 13.04 and use the latest UVCDAT 1.4.1.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .