0

I installed Ubuntu 13.04 in a 16 GB Kingston pen drive (not the "Live", the "Full") using the following partitions: 8 GB ext 4 for "/"; 2 GB for swap; 6 GB FAT 32 free to use just like a pen drive. I can access the 6 GB partition in Ubuntu, but when I try to access in Windows, it tells me that the pen drive is not formated and asks if I would like to do it. Using gparted I recreated the 6 GB partition like NTFS, but I still can't acess it via Windows. That's it: I just want a shared partition which I can access via both Windows and Ubuntu in a pen drive.

0

What is the order your partitions are in?

I'm going to assume you have the 8GB EXT4 at the "front" of the drive.

Windows cannot use/recognize EXT4 partitions, thus it is seeing the first few sectors/spaces of the drive as being EXT4, and yelling at you.

The solution is to start over, and place the storage partition at the FRONT of the drive. If windows sees an NTFS volume, it'll be able to access and use that part of the drive. Note that the drive's capacity would only be 6GB acording to windows, but that's a good thing because this keeps you from screwing up your 'buntu system files from within windows.

| improve this answer | |
  • no problem. I ran into this issue when i tried installing ubuntu on my portable hard drive, and this fixed it. – acolyte Jul 3 '13 at 15:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.