59

I mapped Ctrl-Alt-Up/Down to open web-browser and email client but it didn't take effect. Ctrl-Alt-Up/Down still switch workspaces as the default setting of GNOME 3.8.

I have tried log-out/log-in. No good.

2
  • 3
    In Ubuntu 18.04 these shortcuts were shown as "Super+Down" and "Super+Up" but were actually Ctrl+Alt+Down and Up. In this case disabling these "Super" shortcuts was enough. Dec 23 '18 at 1:02
  • @AgustínLado In my Ubuntu 20.04 system, it's even more strange: the settings that I discovered there were: Super+PageUp/PageDown (to move between desktops in Navigation) -- note Page! -- but those were the bindings that prevented me from using Ctrl-Alt-Up/Down (not PageUp/PageDown) in Emacs. askubuntu.com/a/1367734/19753 Oct 6 at 15:56
95

The new keybinding you define in 'Settings-->Keyboard-->Shortcuts-->Navigation' will get appended to the previous/default one.

It will become, for example.

gsettings get org.gnome.desktop.wm.keybindings switch-to-workspace-down

['<Primary><Shift>Down', '<Control><Alt>Down']

I managed to remove the default keybinding using the following commands

gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-down "['']"
gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-up "['']"

This clears all defined shortcuts for those tasks. And then just use 'Settings-->Keyboard-->Shortcuts-->Navigation' to define the desired shortcuts.

Source : https://bugzilla.redhat.com/show_bug.cgi?id=982695

10
  • 1
    Didn't work for me on Ubuntu 12.04. I.e. used the above gsettings commands, restarted and still ctrl-alt-down/up will switch workspaces.
    – kris
    Jan 2 '15 at 17:20
  • The window docking can be fixed via the CompizConfig Settings Manager. See askubuntu.com/questions/305092/…
    – geneorama
    Mar 19 '15 at 6:34
  • 1
    Worked on Ubuntu 15.04. :)
    – Angelorf
    Jun 22 '15 at 7:55
  • From all possible methods for removing gnome bindings, this is one is the most reliable one IMO. Worked for me on Fedora 23 - Gnome Shell 3.18... Thank you...
    – kbtz
    Mar 30 '16 at 6:38
  • Worked on Ubuntu Gnome 15.10 Apr 4 '16 at 16:56
4

This worked for me on Ubuntu 12.04

Go to "System Settings -> Keyboard -> Shortcuts -> Navigation".

Find the workspace switching shortcuts bound to CTRL-ALT-ARROW. For each one of them do this:

Click on shortcut (so it says "New Accelarator..." allowing you to change the shortcut). Now Press 'Backspace' to clear it. It now says 'Disabled' for that shortcut.

5
  • Do I need to restart for the changes to be applied?
    – Angelorf
    Jun 19 '15 at 11:45
  • It's been a long time ago I disabled this. I'm sorry I can't remember if worked 'instantly' or not.
    – kris
    Jun 19 '15 at 20:49
  • Restart didn't do the trick. The settings are back to normal and changing them never had any effect.
    – Angelorf
    Jun 22 '15 at 7:52
  • The answer by @mac did the trick. The post also has a link to a site explaining the bug I experienced.
    – Angelorf
    Jun 22 '15 at 7:55
  • 1
    To me this is working in Ubuntu 16.04 LTS. No restart needed. My hot key settings in Eclipse Mars conflicts with the system default ones.
    – WesternGun
    Oct 5 '16 at 14:11
4

In Ubuntu 18.04 Settings->Devices->keyboard in navigation search for shortcuts: super+up and super+down and change it, save in button define.

2
  • 1
    Worked in 20.04. But why super is equivalent to Alt + Ctrl ?
    – manikanta
    Aug 12 '20 at 7:25
  • @manikanta In my Ubuntu 20.04 system, it's even more strange: the settings that I discovered there were: Super+PageUp/PageDown (to move between desktops in Navigation) -- note Page, but those were the bindings that prevented me from using Ctrl-Alt-Up/Down (not PageUp/PageDown) in Emacs. askubuntu.com/a/1367734/19753 Oct 6 at 13:18
1

I know this thread is pretty old. For me (Xubuntu 16.04, Xfce4) it helped to use xfce4-settings-editor and then go to xfce4-keyboard-shortcuts. Then scroll down to xfwm4 and "Reset" the bindings for the relevant shortcuts.

1

I tried @mac 's approach but I still could get rid of Control+Alt+Up keybinding. Reading Skype Book's comment here pointed me in the right direction. What did the trick for me was to

  1. install dconf-tools
  2. run dconf-editor
  3. Under compiz->profiles->unity->plugins->grid, removed put-maximize key
1

(The question is more general than just about Ctrl-Alt-Up/Down. As for me personally, I had the problem that my Emacs didn't get Ctrl-Alt-Left/Right. So, I'd like to write an answer with the solution I have found for Ubuntu 20.04.)

Those pointing at the compiz settings were right (via ccsm available after apt-get install compizconfig-settings-manager compiz-gnome, the latter one for /usr/lib/x86_64-linux-gnu/compizconfig/backends/libgsettings.so, although I'm not sure that backend is actually used in my system):

I couldn't find the bindings for these keys via the normal Ubuntu settings menu.

What's new in my answer is that not only compiz's Grid plugin (under "Window Management") could have bound these keys (which you'd like to use in a different way), but also the Desktop Wall plugin (under "Desktop" in ccsm). Especially, the bindings with Left/Right could be found by me to be bound in the latter plugin.

For all 4 (left, right, up, down), you might want to look through the bindings of both these plugins in ccsm (and disable them). Or use the search tool in ccsm to search for "left", "right", etc. in all the values.

After I disabled these bindings in ccsm, Emacs immediately started getting these key combinations. (Finally! That has been so inconvenient for me for so long to have this problem in Emacs whenever I had to use an Ubuntu computer...)

To enable for me the use of Ctrl-Alt-Up/Down in Emacs, I had to look into the usual Ubuntu settings menu, as in https://askubuntu.com/a/1145043/19753 , however, I didn't see such bindings there in the Navigation section of key shortcuts. In despair, I tried disabling the following ones: Super-PageDown/PageUp (note Page!), and that helped.

1
  • OMG! Super-PageDown/PageUp. Thanks. You saved my life! :))) Oct 11 at 11:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.