36

I mapped Ctrl-Alt-Up/Down to open web-browser and email client but it didn't take effect. Ctrl-Alt-Up/Down still switch workspaces as the default setting of GNOME 3.8.

I have tried log-out/log-in. No good.

  • 1
    In Ubuntu 18.04 these shortcuts were shown as "Super+Down" and "Super+Up" but were actually Ctrl+Alt+Down and Up. In this case disabling these "Super" shortcuts was enough. – Agustín Lado Dec 23 '18 at 1:02
59

The new keybinding you define in 'Settings-->Keyboard-->Shortcuts-->Navigation' will get appended to the previous/default one.

It will become, for example.

gsettings get org.gnome.desktop.wm.keybindings switch-to-workspace-down

['<Primary><Shift>Down', '<Control><Alt>Down']

I managed to remove the default keybinding using the following commands

gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-down "['']"
gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-up "['']"

This clears all defined shortcuts for those tasks. And then just use 'Settings-->Keyboard-->Shortcuts-->Navigation' to define the desired shortcuts.

Source : https://bugzilla.redhat.com/show_bug.cgi?id=982695

  • 1
    Didn't work for me on Ubuntu 12.04. I.e. used the above gsettings commands, restarted and still ctrl-alt-down/up will switch workspaces. – kris Jan 2 '15 at 17:20
  • The window docking can be fixed via the CompizConfig Settings Manager. See askubuntu.com/questions/305092/… – geneorama Mar 19 '15 at 6:34
  • 1
    Worked on Ubuntu 15.04. :) – Angelorf Jun 22 '15 at 7:55
  • From all possible methods for removing gnome bindings, this is one is the most reliable one IMO. Worked for me on Fedora 23 - Gnome Shell 3.18... Thank you... – kbtzr Mar 30 '16 at 6:38
  • Worked on Ubuntu Gnome 15.10 – Paulo Pedroso Apr 4 '16 at 16:56
4

This worked for me on Ubuntu 12.04

Go to "System Settings -> Keyboard -> Shortcuts -> Navigation".

Find the workspace switching shortcuts bound to CTRL-ALT-ARROW. For each one of them do this:

Click on shortcut (so it says "New Accelarator..." allowing you to change the shortcut). Now Press 'Backspace' to clear it. It now says 'Disabled' for that shortcut.

  • Do I need to restart for the changes to be applied? – Angelorf Jun 19 '15 at 11:45
  • It's been a long time ago I disabled this. I'm sorry I can't remember if worked 'instantly' or not. – kris Jun 19 '15 at 20:49
  • Restart didn't do the trick. The settings are back to normal and changing them never had any effect. – Angelorf Jun 22 '15 at 7:52
  • The answer by @mac did the trick. The post also has a link to a site explaining the bug I experienced. – Angelorf Jun 22 '15 at 7:55
  • 1
    To me this is working in Ubuntu 16.04 LTS. No restart needed. My hot key settings in Eclipse Mars conflicts with the system default ones. – WesternGun Oct 5 '16 at 14:11
1

I know this thread is pretty old. For me (Xubuntu 16.04, Xfce4) it helped to use xfce4-settings-editor and then go to xfce4-keyboard-shortcuts. Then scroll down to xfwm4 and "Reset" the bindings for the relevant shortcuts.

1

In Ubuntu 18.04 Settings->Devices->keyboard in navigation search for shortcuts: super+up and super+down and change it, save in button define.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.