12

In Xubuntu, how do I remove a startup application that was set in Menu –> Setting –> Settings Manager –> Sessions and Startup without using the GUI? My startup command breaks the gui, and I need to disable it using the command line.

20

Quoting the Xfce Docs ("Some of my applications are always started when I login"):

You can also manually delete those files in ~/Desktop/Autostart and ~/.config/autostart.

For example: open a terminal, type

cd ~/.config/autostart
ls

then rm the files that you want to delete.

| improve this answer | |
  • For Ubuntu 16.04, ~/.config/autostart is the directory – Yu Shen Nov 22 '17 at 19:34
1

You can disable autostart entries by hiding them with a higher-precedence entry.

If you don't have it yet, create your own autostart folder:

mkdir -p ~/.config/autostart

and then create .desktop files matching the names of the ones you want to disable from /etc/xdg/autostart (or other sources such as /usr/share/gnome/autostart).

For example, disabling print-applet:

cat > ~/.config/autostart/print-applet.desktop <<EOF
[Desktop Entry]
Type=Application
Hidden=true
EOF
| improve this answer | |
  • While this is likely a bug in the way current gnome-session and gio interact, the hiding desktop file will be ignored if it doesn't contain a Type=Application key-value pair as well. – Gabriel Apr 7 at 11:34
  • Also, I wouldn't be surprised if some desktops fail to hide the entry if not providing a Name key as well. – Gabriel Apr 7 at 11:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.