So I'm planning on testing out Ubuntu Touch, and developing some applications for it so I thought I would flash it to my Nexus 4 that was already unlocked, and running Paranoid Android and the kernel associated.

I headed to Ubuntu's website, browsed around and came across this page: Touch/Install - Ubuntu Wiki

I followed Step 1 perfectly, word by word. Its seems to me that everything on that part is fine. I skipped Step 2 having already done that for Paranoid Android, and then I follow 3 and 4 word to word also.

Using the command phablet-flash -b everything seemed to be fine. So it booted up and all seemed normal, but it wasn't.

Here are some major bugs that only seem to happen to me.

So I was greeted with a normal lock screen:Ubuntu Touch lockscreen

But one of the first noticable things on the home screen is that I only have 4 tabs, not 5:

Some of the applications that are supposed to work do not (I know some are dummies) like here with the calculator, this is what I get: Calculator app On the homescreen it is a black box, it will crash a couple of seconds later: Calulator app on home screen

Another annoying problem is that when I want to close apps, I have from right to left, if I close an app on the left first it will close it, but it will open the app to it's right, weird: Closing apps

Yet another bug, this one is in the pull down drawer, when you just click on it, you can see that not all the icons are there: Pull Down drawer

Pretty much everything else works as it should, but my main problem is that there is no telephony, I'm not sure how it works exactly, but I'm never asked a SIM code (I'm guessing you need that?), I can't compose SMS's and can't dial numbers, it won't let me select the 'Send' or 'Call' button.

I've after tried manual installs all over the place with these files:

There are some weird size differences between what the site told me and what I downloaded, but I've tried re-downloading just to end up with the same file.

And it just alway ends up with the same problems. No telephony and those weird bugs.

So my question is, how the hell can I get the same version as everyone else, with the ability to send texts and call and open the calculator and more?

Also, definitely running saucy: Saucy! And maybe useful? This is what's in the device info: Settings app

  • Just tried this yesterday on my N7 and I have the same issues. Will continue to research. Many, many apps totally broken - dying with either a white or black screen. Same issues as you're experiencing (or were, back in July), but this is nearly October. Hopefully a re-install will fix. – Scaine Sep 24 '13 at 20:14
  • 1
    Oh, I forgot to say, I don't have the problem any longer, it wasn't really a problem in the first place, just that daily image was rather broken. – Alex Sep 25 '13 at 16:52
  • 1
    I re-installed "Devel Channel" as the WIKI points out - still buggered. I re-installed "Stable" and it mostly works. Still loads of things broken, like you can't launch Gmail webapp from the home scope, but it works in the Apps scope. Weird. Pretty unusable so far. Hopefully it pans out better than this for the final release (as I'm sure it will). – Scaine Sep 28 '13 at 20:39

Just that specific daily image had some broken features, and my misunderstanding on lots of things.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.