To enable ftp service recently I have installed vsftpd using this instructions in my ubuntu web server. But I'm still unable to access my server directory using ftp. I don't know what to do or what's the problem.

say, my domain test.test2.example.com and able to access it using ssh from remote. Like:

ssh -Y user1@test.test2.example.com

but not able to access through ftp, using:

ftp test.test2.example.com

it's showing ftp: connect: Connection timed out

I thought ftp service is not installed into my server, that's why I installed vsftpd. But it's still not working out.

Updated with vsftpd configuration file

# Example config file /etc/vsftpd.conf
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
# Run standalone?  vsftpd can run either from an inetd or as a standalone
# daemon started from an initscript.
# Run standalone with IPv6?
# Like the listen parameter, except vsftpd will listen on an IPv6 socket
# instead of an IPv4 one. This parameter and the listen parameter are mutually
# exclusive.
# Allow anonymous FTP? (Beware - allowed by default if you comment this out).
# Uncomment this to allow local users to log in.
# Uncomment this to enable any form of FTP write command.
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
# If enabled, vsftpd will display directory listings with the time
# in  your  local  time  zone.  The default is to display GMT. The
# times returned by the MDTM FTP command are also affected by this
# option.
# Activate logging of uploads/downloads.
# Make sure PORT transfer connections originate from port 20 (ftp-data).
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
# You may override where the log file goes if you like. The default is shown
# below.
# If you want, you can have your log file in standard ftpd xferlog format.
# Note that the default log file location is /var/log/xferlog in this case.
# You may change the default value for timing out an idle session.
# You may change the default value for timing out a data connection.
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that on some FTP servers, ASCII support allows a denial of service
# attack (DoS) via the command "SIZE /big/file" in ASCII mode. vsftpd
# predicted this attack and has always been safe, reporting the size of the
# raw file.
# ASCII mangling is a horrible feature of the protocol.
# You may fully customise the login banner string:
#ftpd_banner=Welcome to blah FTP service.
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
# (default follows)
# You may restrict local users to their home directories.  See the FAQ for
# the possible risks in this before using chroot_local_user or
# chroot_list_enable below.
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
# (Warning! chroot'ing can be very dangerous. If using chroot, make sure that
# the user does not have write access to the top level directory within the
# chroot)
# (default follows)
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
# Customization
# Some of vsftpd's settings don't fit the filesystem layout by
# default.
# This option should be the name of a directory which is empty.  Also, the
# directory should not be writable by the ftp user. This directory is used
# as a secure chroot() jail at times vsftpd does not require filesystem
# access.
# This string is the name of the PAM service vsftpd will use.
# This option specifies the location of the RSA certificate to use for SSL
# encrypted connections.
  • What version of Ubuntu are you using ? 10.04 ? Are you using a firewall or behind a router ? did you forward the ports ? Can you elaborate on your configuration ? Did you follow all the sections ? "Securing FTP" ? – Panther Jul 2 '13 at 16:12
  • I'm using 12.04. I ran ufw status and it's saying Status: inactive. I also allowed port 20,21 and 22. Yes I've followed "Securing FTP". Although I just updated my question with vsftpd configuration file. Please help. – rony36 Jul 3 '13 at 6:54
  • Having the exact same problem as OP here, any solution? – gromit190 Aug 29 '16 at 10:09

Since SSH is working fine you should use scp to copy files on the command line. You can also connect to the server via FileZilla using the SFTP protocol. To do this just connect to the server in FileZilla and use port 22.

FTP is not secure so you should avoid using it when possible.

| improve this answer | |

Most likely your ftp client does not support the security mechanisms used by vsftpd.

Try using lftp, which supports FTPS.

sudo apt-get install lftp
lftp -u user1 test.test2.example.com

If that's still not working, then I recommend port scanning your FTP server. Perhaps a firewall is getting in the way.

sudo apt-get install nmap
sudo nmap -PN test.test2.example.com
| improve this answer | |
  • thank you for your help. But I need to access through FileZila too. :( – rony36 Jul 2 '13 at 13:42
  • What were the results of the nmap command? Also, can you connect to the ftp server from itself. For example, on your server can you use ftp localhost ? – Nate from Kalamazoo Jul 2 '13 at 14:40
  • yes, my server can use ftp localhost and it's working fine. But in FileZila. HOST: test.test2.example.com it's showing time out error. I tried ftp.test.test2.example.com too – rony36 Jul 3 '13 at 6:37
  • What were the results of the nmap command run from your client machine? sudo apt-get install nmap && sudo nmap -PN test.test2.example.com – Nate from Kalamazoo Jul 5 '13 at 18:32

I had the exact same problem as you, OP. It appears that there is a firewall on the server, blocking the connection. I resolved it by adding the following entries to my /etc/rc.local file:

iptables -A OUTPUT -p tcp --sport 21 -m state --state ESTABLISHED -j ACCEPT
iptables -A OUTPUT -p tcp --sport 20 -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -A INPUT -p tcp --dport 21 -m state --state NEW,ESTABLISHED -j ACCEPT
iptables -A INPUT -p tcp --dport 20 -m state --state ESTABLISHED -j ACCEPT

You might have to reboot the server for it to work

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.