32

I installed Dropbox (2.0.26) via the command line instructions here.

Dropbox is running great except that it won't start on startup. The command given, ~/.dropbox-dist/dropboxd, runs fine via the terminal or Alt+F2, but it isn't working in Startup Programs.

I'm probably missing something obvious regarding the syntax for a startup program command. Any suggestions?

6
  • Did you have some reason for preferring the CLI route? I installed Dropbox via the GUI route just the other day and have version 2.2.3. Dropbox starts automatically on logging in. I didn't have to do anything.
    – user25656
    Jul 1, 2013 at 17:06
  • The download link at Dropbox links to version 1.6, which was not syncing consistently for me. The CLI route gave me a later version. Jul 1, 2013 at 17:18
  • 1
    See these two links: 1 --- dropbox.com/download?dl=packages/ubuntu/dropbox_1.6.0_i386.deb and 2 --- dropbox.com/download?dl=packages/ubuntu/dropbox_1.6.0_amd64.deb. It says 1.6.0 but the Dropbox version installed is 2.2.3 which I see when I hover on the little Dropbox icon in my panel.
    – user25656
    Jul 1, 2013 at 17:22
  • Thanks for the pointer, vasa1. I installed the deb and I got the startup options back in preferences. Oddly, it is still version 2.0.26 for me though. Jul 2, 2013 at 13:31
  • Did you do a thorough uninstall of Dropbox first? Including any config files in your home folder? Anyway, I'm pretty new to Dropbox myself!
    – user25656
    Jul 2, 2013 at 13:38

11 Answers 11

25

Follow these steps to make Dropbox start up each time.

  1. Click on the Ubuntu "Dash" icon
  2. Type Startup Applications in the Dash search area
  3. Click on the "Startup Applications" ico
  4. Click "Add" button
  5. For "Name:", type Dropbox
  6. For "Command:", type /home/{your-username}/.dropbox-dist/dropboxd
  7. For "Comment:", this can be left blank
  8. Click "Add" button
  9. Click "Close" button
  10. Restart your computer
4
  • This works! This is also the default way to do this. I think this should be the accepted answer. Dec 31, 2015 at 9:35
  • 1
    This also worked in Lubuntu 20.10 with minor adjustments. Selecting the checkbox from the Dropbox preferences doesn't work when the installation has been done in command line, as mentioned in other comments.
    – Gemmu
    Mar 31, 2021 at 11:01
  • This worked for me, except that when I rebooted the machine remotely and logged in via ssh (something that has become routine during the pandemic...) it doesn't autostart. This shouldn't be a surprise since I'm not starting a gnome session when I ssh to the machine. May 6, 2021 at 0:45
  • This simple GUI-oriented recipe works on Ubuntu 20.14LTS. However, I still wonder what an effective command line equivalent is. I had tried the dropbox autostart y option and it did not work for me. Sep 5, 2021 at 3:25
20

Click on the dropbox icon on the top of your screen, hit "preferences" and tick the button where it says "Start dropbox on system startup" in the "general" tab.

7
  • 1
    I felt like an idiot for a moment :) but it seems that the option doesn't exist in preferences. My General tab only has boxes for Desktop notification and LAN sync. I feel like you are right that it was there previously, but it isn't now. My version is 2.0.26 if that helps. Jul 1, 2013 at 14:42
  • 1
    As per the comments with vasa1, the CLI install seems to have been missing this option, but if you install the deb directly, you will get the option back. Jul 2, 2013 at 13:46
  • 3
    This is not working for me. When I start it from a command line (as described above) the icon appears on the task bar. I right click, go to preferences and select "Start dropbox on system startup" and click ok. I reboot the machine and it's not running.
    – mbmast
    Aug 13, 2015 at 18:20
  • 10
    This does not work if dropbox installed by the terminal command. Dropbox forgets the setting each time restarting. Dec 31, 2015 at 9:36
  • 2
    @LéoLéopoldHertz준영 , indeed. For Dropbox to autostart without forgetting the setting, I ran nautilus-dropbox autostart y or caja-dropbox autostart y if you are using a Mate Desktop Environment
    – xcvbn
    Jan 4, 2017 at 9:31
8

In the terminal, type

dropbox autostart y
1
  • This is set by default so it's unlikely to be a solution.
    – Andrew
    Mar 9, 2019 at 2:08
8

First you have to create a dropbox.desktop file, with the following contents:

[Desktop Entry]
Name=Dropbox
GenericName=File Synchronizer
Comment=Sync your files across computers and to the web
Exec=dropbox start -i
Terminal=false
Type=Application
Icon=dropbox
Categories=Network;FileTransfer;
StartupNotify=false

Once its created, you need to move it to ~/.config/autostart folder, reboot, and that's it.

enter image description here

Remark: if dropbox was installed from the command line, the line "Exec=dropbox start -i" doesn't work, it needs to be replaced by "Exec=/home/username/.dropbox-dist/dropboxd" where /home/username is your home directory.

5
  • This fixes the problem of autostarting dropbox for Kubuntu 15.04!
    – Veger
    May 23, 2015 at 7:23
  • This does not work on Debian 8.
    – mbmast
    Aug 13, 2015 at 18:38
  • I think you will have a permission problem with such a setup. It is not working in Ubuntu 14.04 LTS, although with permissions 755. Dec 31, 2015 at 9:38
  • @Masi Its working OK on 14.04.03. It's been working since the release of 14.04. You might have other issues.
    – Mitch
    Dec 31, 2015 at 10:59
  • RHarris answer works in my setting. Dec 31, 2015 at 11:07
5

Try this command:

sudo apt-get install nautilus-dropbox

It ships in the autostart function.

2
2

I tried all the other methods: Only this method as stated by previous user has worked for me:

Run:

cd /usr/bin

Then rename executable with this command:

sudo mv dropbox dropbox1 

Then create a new file called dropbox using command:

sudo gedit dropbox

Then write this:

#!/bin/bash
~/.dropbox-dist/dropboxd

Save and exit, change premission:

sudo chmod 0755 dropbox

then restart the computer.

OR

Create a startup application with name say "Dropbox2" and write this line in it.

sh -c  ~/.dropbox-dist/dropboxd

Save and exit, then restart the computer.

One of the 2 work properly.

1
  • @sijoune rejected edit, because your suggestion will create a new dropbox file in /usr/bin without execution rights.
    – MadMike
    Dec 7, 2014 at 22:38
1

To add any program on startup, go to 'Dash Home' and choose 'Startup Applications'. There you can add any program that wish to run on startup.

3
  • I have done that. My problem is that the command described in my question does not seem to run from "Startup Applications" despite running fine in the terminal and via Alt+F2. Jul 1, 2013 at 14:51
  • Open 'Startup Applications' click 'Add' and enter 'dropbox' in the 'Command' field and see if it works. Jul 1, 2013 at 15:01
  • I tried that. Unfortunately, it doesn't work. Jul 1, 2013 at 16:39
1

Create a startup application with name say "dropBOX" and write this line in it.

sh -c  ~/.dropbox-dist/dropboxd

Save and exit, then restart the computer.

1

This is the only way (and incidentally, the easiest way) I could get this to work on 14.04 without a buggy install or doing a .desktop file (which I couldn't get to work). I had to install the .deb using these instructions:

sudo apt-key adv --keyserver pgp.mit.edu --recv-keys 5044912E

sudo add-apt-repository "deb http://linux.dropbox.com/ubuntu $(lsb_release -sc) main"

sudo apt-get update

sudo apt-get install dropbox

Then you should get a prompt to install Dropbox from the GUI (if you don't, search in your Applications for it and run by clicking the icon). Once Dropbox is installed and you're logged in, the preferences should default to autostart, but in case they don't, you can right-click on the Dropbox icon, go to "Preferences", and check "Start Dropbox on System Startup"

Got the instructions from this answer (which seems to have been lost in the annals of the forum for some reason): Running Dropbox at startup

1
  • Needed to also do sudo apt-get install build-essential before dropbox, otherwise there is a failure...
    – ntg
    Jun 8, 2015 at 16:14
0
sudo apt-get install nautilus-dropbox
dropbox start

after you install the nautilus-dropbox you will find dropbox on the startup applications list and check it. :)

4
  • 1
    It causes one time start, not autostart.
    – enedil
    Aug 25, 2014 at 21:56
  • after you install the nautilus-dropbox you will find dropbox on the startup applications list and check it. :)
    – Ayo
    Aug 26, 2014 at 2:42
  • I tried this solution but it installed an old version of dropbox (1.4) which is not functioning correctly. Oct 4, 2014 at 19:22
  • dropbox autostart -y Jun 2, 2018 at 18:18
0

you need to connect it to your account... If you have no gui, you can do it by running the server (after installation), try

dropbox start
dropbox status

if it is not running, try running the demon directly, and it will give you a link to enter from another computer to verify password, e.g.:

~/.dropbox-dist/dropboxd
This computer isn't linked to any Dropbox account...
Please visit https://www.dropbox.com/cli_link_nonce?nonce=adfalhwelkjfhlasdk to link this device

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.