I have installed Keepass2 from the Ubuntu Software Center and Keefox in Firefox. The setup works fine. Both can communicate with each other.

However, every time I start Firefox I'm greeted with the same window asking me to configure it all over again even though there is no need.

How can I fix it? There is no obvious setting in the extension or about:config to change this behaviour.

enter image description here


You do not need to use application plus add-on.

All i use is Keepassx, no other application or firefox add-on required. You can use a global hotkey with keepassx. Once setup step 1) enter global hotkey 2) enter password = All done.

Youtube link on instructions: http://www.youtube.com/watch?v=_BM8XxS1jUE

  • Hey, you're right! This Auto-Type feature is all you need. Since I'm required to have the main application open in both cases as the browser extensions aren't able to decrypt the database by themselves this is just as convenient. – user24668 Jul 1 '13 at 11:58
  • But what do you mean by "global hotkey"? Do you use this application differently than explained in the video? In the video it is still necessary to enter KeepassX everytime to 'copy' a password. – user24668 Jul 1 '13 at 11:59
  • Oh no, this is not good. Many times this application does not enter the passwords in the correct fields, e.g. in a search field etc. This is a no go.... I love buggy security software :D – user24668 Jul 1 '13 at 18:29
  • Is Keepassx able to automatically remember passwords? – utapyngo Feb 24 '15 at 15:33

Probably worth taking a look at this page if you've not already: https://github.com/luckyrat/KeeFox/wiki/en-|-Installation-|-Linux

The setup tab appears because KeeFox does not think that you have setup everything correctly.

The above page and/or manually entering the paths in the Options/KeePass panel should do the trick but if not you could try the KeeFox help resources: http://keefox.org/help

The path information should be explained on the setup page but it's possible this is different in non-English languages.


I had the same issue. Everything worked well except for that nasty install page re-apearing every time. The solution was to go to keefox settings and to enter the path to the keepass2 folder which was empty before.


Global Hotkey = A keyboard key combination e.g. ALT+SUPER+P. The program you have to enter the fields then do not forget to press the save icon otherwise you will loose your settings, i should know i did the same thing. I am using this on Xubuntu and it works perfectly.


I had this problem as well a while back.

What I did was go to KeeFox's Options > Connection Security and lower the security level (I don't remember the exact values I had)

Keep in mind this is not a real fix though, more of a band-aid.


When i had the issue i solved it by copying the plgx again. Everything worked just fine before, but i suppose KeeFox updated and was expecting a newer version of KeePassRPC too. I was hesitant to set it up again because i had done so before, but when i copied the rpc plugin supplied by KeeFox again everyting worked as expected.


On the KeePass settings page that other answers mention, I had to check the checkbox for "Remember above settings (e.g. when using KeePass Portable)", even though I was not using a portable location. I am using a portable download, so possibly that is what the option is meant for. Now it works!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy