I understand that the issue of Canon printer under Linux has a number of posts. Actually one of these, was started by me. After inputs from others I have successfully printed using Canon LBP6000 from my Ubuntu machine for around a year. If it failed to print, restarting the daemon using this homemade script coaxed the printer to print.


pkill -9 -x ccpd
pkill -9 -x captmoncnabc
/etc/init.d/ccpd start
/etc/init.d/ccpd status

Recently, I am not successful any more, or successful on a limited and sporadic basis. Sometimes it prints when turned on after logging in, sometimes when the driver is reinstalled. I keep on trying the random steps (call abracadabras) until I get success. Again, not always success comes. I frustrate on for hours only to get single page printed. I loose precious time on the issue of printing.

I have read and read all the documents available over the Internet. However, if you please notice, none of the guides, articles, tutorials (these are too many to list here) seem to be dealing with diagnosing the problem when it fails to print. They tell you where to find the drivers, how to install them, or which script to run to make the installation process automatic. Yes, some of the articles or comments suggest a step to try, without any systematic order. But these fail to suggest a step based on symptoms, mostly.

This morning, my Canon LBP6000 failed to print. After sometime, there was a message for system error, details of which was found to be something like this.

enter image description here

When I search for this error (c3pldrv crashed with SIGSEGV in write ()), I find a number of articles including this one. None of these are actually helpful. Mostly, these are 'me too', 'tell me if you find anything'.

Running captstatusui -P LBP6000 produced this,

enter image description here

Yes, the printer is connected and actually turned on.

I believe that there are a number of frustrated Canon printer users out there like me. But there is not a step by step definitive guide to systematically diagnose a non-printing printer.

Do you think that you can provide your diagnosing inputs so that a systematic document can be built?

May be we will want the Ubuntu users to stay away from Canon printers. But as I believe, as a Linux user for more than fifteen years, such a scenario is not acceptable any more. May be this was acceptable in the infancy days of Linux, but not today.

I am using Ubuntu 12.04, by the way, I prefer LTS versions.

  • Would you like to share your script? I am getting black pages sometimes printing with UFR2 driver from canon. This does happen on some documents only, not at all.
    – Piotr K
    Feb 24, 2015 at 12:14
  • @PiotrK The answer is a definite yes. Would you like to be a bit more specific which script you are referring to?
    – Masroor
    Feb 24, 2015 at 15:23

4 Answers 4


This is not simply a "me too" post. I have been researching for a year and a half, in detail, how to make my Canon ImageClass D420 laserjet all-in-one work with Linux. Bottom line - Try the latest drivers (2.7 - June 2013) from Canon then sell your Canon and buy something that works! If time is money, and you value either one, sell it sooner rather than later.

I started out with Ubuntu 12.04 (64-bit) only to find that almost no one had succeeded in getting many of the Canon Laserjets to work. I kept at it with countless hours of research and eventually got the printer to work on a very marginal basis. I apologize that much of that 64-bit knowledge was "dumped" or became dated with semi-annual upgrades as I ventured into Mint Mate (Xfce desktop) with 12.10 and Xubuntu (Xfce desktop) for 13.04. But the same issues with Canon drivers persisted. During June '13, Canon released their 2.7 drivers. I was pleased that my LaserJet worked right off the bat (as well as it ever did). However, I still needed to shut off the power to the printer between print jobs to get it to work.

Since so many users encountered most of their problems with 64-bit versions, I decided to go with 32-bit Xubuntu (excellent!) for 13.10. This download from Canon (look for your specific model) includes .deb files for: cndrvcups-ufr2-us_2.70-1_i386.deb and cndrvcups-common_2.70-1_i386.deb

I think the common file needs to be installed before the ufr2 (if it doesn't work one way try the other). Next, printer settings have to be set to recognize both your printer and the connection, not as easy as one would think.
My settings:

Description: Canon D400-450 (UFRII LT)

Connection: usb://Canon/D400-450%20(UFRII%20LT)?serial=SJ3026

Device URI: Canon D400-450 ver.2.7

After a lot of tinkering, sweat, cursing and time, the Canon doesn't work any better than it did with my first frustrating experience a year and a half ago and three separate Ubuntu installations later. Yes, I can print some of the time - if I shut it off between print jobs. I have great difficulty printing .pdf files from my browser or email. I can work around this (most of the time) by printing to file first - then printing the .pdf from my local file. However, just today, I printed a 30 page .pdf document. It printed 30 pages of solid black! Never did get it to print correctly using all my tricks. After giving up on it and trying to print a USPS mailing lable, I noticed my CPU indicator was PEGGED and task manager told me 'C3pldrv' was using 90% of the CPU capacity. After closing all programs and rebooting everything was fine - and the printer spit out my mailing label without being prompted.

The bottom line of four installations and tons of research is that the Canon LaserJets and all-in-ones should be avoided like the plague. But then, you wouldn't be reading this had you bought something else. And that is just the printer portion of this Canon. I have had absolutely NO success with the scanner. The Canon scanner tool does not work with this machine. "No devices recognized" I have tried so many SANE front ends back ends and upgrade tricks it has driven me in-SANE. The one ray of hope for the scanner is to use VueScan ( a fantastic (low-riced) scanning application which was developed with Ubuntu ) with their recommendations. I am going to try that again as I found it at a critical moment when I actually had to get some work done other than trouble shooting the Canon. Good luck - I'll follow up with more info as I get it.

  • My printer now works, and it works every time. But there is a small catch. I need to run a (homemade) script as user root before a print. I do not want to try any new driver at this moment. I am not particularly eager for another set of frustrating days and nights. Yes, you are right, I would not not be reading this if I owned something else. And in future I plan to do exactly the same. I will never buy another Canon printer for my personal use.
    – Masroor
    Nov 27, 2013 at 4:39
  • +1 for "Canon LaserJets and all-in-ones should be avoided like the plague". I have a Canon I-Sensys mf4120 and it does not handle file sizes greater than ~1 Mb, under Linux or Windows. Under Linux it has a bunch of subtle and irritating bugs, even if it works. Aug 1, 2014 at 8:21

I had a case when latest driver version 3.40 did not work for Canon MF4120 on Kubuntu version 17.10:

c3pldrv -i 6 -o 11 process used 100% of one CPU core when I tried to print something. Strace showed that it constantly tried to read(12, "", 6).

Fortunately previous driver version 3.10 works! I just had to ignore dependency libpng12-0, which is missing on Ubuntu 17.10.

Installed package libpng16-16 did not satisfy the .deb package requirements, so I had to ignore the dependency:

dpkg --ignore-depends=libpng12-0 -i cndrvcups-common_3.40-1_amd64.deb cndrvcups-ufr2-uk_3.10-1_amd64.deb

Unfortunately it leaves "broken package", so later I modified the cndrvcups-ufr2-uk_3.10-1_amd64.deb and in control file I replaced libpng12-0 by libpng16-16. Deb file can be modified using Easily unpack DEB, edit postinst, and repack DEB.

Then reinstalled modified package and that's it.


Now (in 2016) it works well in Ubuntu, although it still took some trouble to figure out the steps. It boils down to this:

  1. Download UFR II/UFR II LT Printer Driver for Linux Version 3.10. One source is: http://support-asia.canon-asia.com/contents/ASIA/EN/0100270810.html.

  2. Open a terminal (press CTRL-ALT-T).

  3. Extract the downloaded file and enter the installation directory:

    cd ~/Downloads
    tar zxvf Linux_UFRII_PrinterDriver_V310_uk_EN.tar.gz
    cd Linux_UFR*
  4. Now run the installation script as root. The script has tweaks in it to work for most linuxes, including ubuntu.

    sudo ./install.sh
  5. That's it! Now, open a PDF and print to try.

Most instructions on the web asked to install the printer drivers directly by double clicking the .deb files in the extracted directories. This did not work. The key is to run the installation script (step 4 above). This worked, for me.

  • Thanks. But after months of exasperation, I got rid of Canon and bought another brand (Brother). This one worked out of the box.
    – Masroor
    Feb 5, 2016 at 0:45
  • I have a cannon 6030 printer and I also need to power down. I downloaded Linux_UFRIILT_PrinterDriver_V130_uk_EN and I ran the script. My page size is always letter (i am a4). If I print one page.. ok. Reprint.. need to power down. When I was installing.. got these errors Unable to locate package libbeecrypt7:i386 E: Unable to locate package libbeecrypt-dev:i386 Jun 11, 2016 at 14:56

I struggled for hours until it finally worked first download the driver from canon site for linux ver 3.0 once downloaded you need to extract it with archive manager


then you will see a folder with the same name you open it, extract it and there are 32 bit folder and 64 bit folder

I opened 64 bit folder because my computer is 64 bit you also open /home/jxxx/Downloads/cups-2.1.0-source.tar.bz2 folder extract it , a debian folder extract it there are 2 folders here open both right click run
go to settings to add a printer click ppa file and search it in your computer click on Linux_UFRII_PrinterDriver_V300 and Voila! print test done

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .