4

I'm using Ubuntu 12.04 LTS with Dell power-edge R720 server, facing the problem when I

apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up linux-image-3.2.0-37-generic-pae (3.2.0-37.58) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
The link /initrd.img is a dangling linkto /boot/initrd.img-3.2.0-37-generic-pae
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.2.0-37-generic-pae
 /boot/vmlinuz-3.2.0-37-generic-pae
update-initramfs: Generating /boot/initrd.img-3.2.0-37-generic-pae

gzip: stdout: No space left on device
E: mkinitramfs failure cpio 141 gzip 1
update-initramfs: failed for /boot/initrd.img-3.2.0-37-generic-pae with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-3.2.0
-37-generic-pae.postinst line 1010.
dpkg: error processing linux-image-3.2.0-37-generic-pae (--configure):
 subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of linux-image-generic-pae:
 linux-image-generic-pae depends on linux-image-3.2.0-37-generic-pae; however:
  Package linux-image-3.2.0-37-generic-pae is not configured yet.
dpkg: error processing linux-image-generic-pae (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup erro
r from a previous failure.
                          Errors were encountered while processing:
 linux-image-3.2.0-37-generic-pae
 linux-image-generic-pae
E: Sub-process /usr/bin/dpkg returned an error code (1)
------------
even i tried with apt-get clean
apt-get remove
apt-get autoremove
apt-get purge
there is no difference it will show the same error message as above,
even i checked the disk space
-----------
Filesystem     1K-blocks      Used Available Use% Mounted on
/dev/sda6       24030076    612456  22196964   3% /
udev            16536644         4  16536640   1% /dev
tmpfs            6618884      1164   6617720   1% /run
none                5120         0      5120   0% /run/lock
none            16547208        72  16547136   1% /run/shm
cgroup          16547208         0  16547208   0% /sys/fs/cgroup
/dev/sda1          93207     75034     13361  85% /boot
/dev/sda10       9611492   1096076   8027176  13% /tmp
/dev/sda12       9611492    226340   8896912   3% /opt
/dev/sda13       9611492    152516   8970736   2% /srv
/dev/sda7        9611492    592208   8531044   7% /home
/dev/sda8        9611492   2656736   6466516  30% /usr
/dev/sda9        9611492    696468   8426784   8% /var
/dev/sda14     961237336 134563516 777845764  15% /usr/data
/dev/sda15     618991384  84498388 503050052  15% /usr/data1
/dev/sda11       9611492    152616   8970636   2% /usr/local
--------------- 

is there any problem on allotting the space to the partiations please let me know the solution its on urgent

please help me on this issue regards

  • 3
    The error says it all: No space left on device. Your /boot partition only has 13MB free. Either you need to remove older kernels (if not needed) or you need to increase that partition size. – Salem Jun 30 '13 at 20:20
5

just running:

sudo apt autoremove

solved my problem

related: https://help.ubuntu.com/community/RemoveOldKernels

1

See How do I remove old kernel versions to clean up the boot menu? for removing old kernel images.

To rebuild the initial ram disks for the remaining kernels (ensuring that everyone has one properly built) run:

sudo update-initramfs -k all -u

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.