68

I tried many ways to make a bigger screen in VirtualBox because I do not like the small size of the guest window? Is there is a way to make it big?

75

View -> Switch to Fullscreen Mode (or HOST+F)

Right CTRL is normally the default HOST key.

You need to install the Guest Additions to be able to adjust the guest screen geometry to the host in fullscreen mode.

Here are different instructions to install Guest Additions.

  • 4
    For me this just makes the VirualBox instance fullscreen, not the cilent computer (there are grey borders on each side of the client OS's screen, which is as big as before HOST+F) – lindhe Nov 9 '13 at 15:34
  • 1
    From within the virtual machine, try adjusting the resolution? ie: In Windows, go to Control Panel and set your resolution. – earthmeLon Nov 12 '13 at 18:54
  • Does not help - it does not show the resolution of my physical screen as maximum, but some "preset" or virtually defined one. Maybe I should set a screen resolution in the VB settings for that machine? – lindhe Nov 12 '13 at 21:22
  • 4
    Correct answer is to install Guest Additions: askubuntu.com/questions/184794/… – gspatel Apr 20 '14 at 8:26
  • After installing "Guest Additions" I was able to make full screen – Raghav Feb 2 '18 at 18:32
13

You need to install the Guest Additions go to devices menu > select "install guest additions" after installation restart virtual system now select view menu and click "switch to full screen"

5

I tried the solution provided by Mawhrin-Skel. However, it didn't work for me the first time. Then I installed virtualbox-dkms and virtualbox-guest-dkms and tried the solution again. This time it worked for me. Following are the steps that I followed

  1. Click Devices -> Insert Guest Additions CD image from the menu of the VM window
  2. Restart the VM

Then:

sudo apt-get install virtualbox-dkms
sudo apt-get install virtualbox-guest-dkms
sudo apt-get remove libcheese-gtk23
sudo apt-get install xserver-xorg-core
sudo apt-get install virtualbox-guest-x11

Hope this helps

  • This works for me – RJ45 Nov 24 '16 at 10:59
  • This broke my virtual machine... after 2 hours of installing. noooooo! Its going all spastic now, resizing, popping up and down.. then nothing! omg! :( – ppumkin Sep 26 '17 at 14:56
  • This worked for me - might be helpful if you could say how it works. – Don Shanil Sep 13 '18 at 12:54
2

You need to enable "Scaled Mode" after installing Guest addons. Host+C

  • 1
    A bit more information would help. – George Udosen Jan 20 '17 at 15:25
  • I found this helpful. It is the correct answer for console if you don't want to have a small box on the screen. For GUI the accepted answer works better. – Spikolynn Feb 5 '17 at 20:41
1

You should run the following commands in a terminal on your host Ubuntu session:

sudo apt-get remove libcheese-gtk23
sudo apt-get install xserver-xorg-core
sudo apt-get install virtualbox-guest-x11
  • What do they do? – Mukus Aug 19 '15 at 0:03
1

Once you have installed Windows Operating system go to the resolution settings by >Right Click > Screen Resolution > change to (1920 x 1080)

If this does not work keep trying each resolution within the Settings. You should come across one which will fit your screen.

Don't forget to also (Auto Fit Guest) within the Virtual Machine View Settings.

1

Devices --> Click on Insert Guest additions CD image option

If you have installed Ubuntu via Virtual Box on MacOS and experiencing an issue while trying to make the window size full screen, the solution is as follows.

Once Ubuntu has been installed, go to the the Virtual Box Menu Bar Devices -> Click on Insert Guest additions CD image option

Now, within Ubuntu you will be asked to provide sudo password and it builds the Virtual Box Guest Additions kernel module.

After restarting the VM , click on View -> Full Screen size and that should modify your display.

0

if using virtual box to use ubuntu on any other host.

  1. Start the virtual machine, when ubuntu is booting up switch of virtual machine immediately.
  2. Start the machine again, and when ubuntu prompts some boot up options, select the first one...
  3. Your Ubuntu will start with a bigger screen size in comparison to the older one.
0

I was also very confused on this at first, but I figured out how.

This tutorial will work for most OS'es

First, you need to click on "Devices" on the bar at the top.

A pop down window will appear, so now you need to click "Insert Guest Additions" or something like that.

If you're using Windows XP or around that OS, then it will automatically pop up and start installing.

However, it will not happen on Windows 7 - 10. Therefore, we need to do something else.

Click on File Explorer, or search up in search "File Explorer", and it should look like a file inside a cabinet.

If you are on Ubuntu or other Linux, just search up "Files", and it should be one of the main results.

The photo of the File Explorer icon will be shown below.

Click here to view the File Explorer Icon

Now, in the left side, there is a bar which shows "Quick Access", "This PC", and maybe some others.

It looks like this.

Now look next to the tab called "This PC", and there will be a small arrow on the left side of it. Press that, and you will see folders such as "Desktop", "Documents", and many more.

At the bottom, it should say something like "DVD Drive (E:) VirtualBox Guest Additions."

Click on it, and there will be many files. You have to double-click the file called VBoxWindowsAdditions.exe (If you are on Windows). On Linux, it will be similar, but don't select any of the AMD64 or x86 ones.

The file that you have to press will be shown in this image.

Go throught the steps, allowing all of it when it asks, and when it is done, click "I want to reboot now", and when you go back in, wait a few seconds, and it should automatically resize to fit the whole screen. Then you can press Right Ctrl + F (unless you changed the host key), and it will be almost perfect.

...Except for that little sliver on the bottom. It must go away, or our almost perfect virtual machine won't have that nice feel to it.

Close the virtual machine (completely close, not just save state), and right click the virtual machine you are doing this on. Choose "Settings", and go to the "User Interface" tab at the bottom.

There will be a checkmark that says "Show bar in fullscreen mode" or something like that, and it is checked by default. Uncheck it, apply the changes, and open the virtual machine.

Ta-da! The virtual machine does not look like a virtual machine anymore. It looks like your actual computer.

Now to get out of the fullscreen virtual machine, press the host button + F. The host button by default will be the right Ctrl key on your keyboard (Unless you changed it).

Now you know how to get to fullscreen without any distractions from your experience.

If this helped, then please upvote it and support it.

Hope this helps!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.