15

For my daily work I use two keyboard layouts: The normal German Qwertz (setxkbmap de) as well as Neo (setxkbmap de neo). Yesterday suddenly between switching back and forth between keyboard layouts alt and super stopped working normally for window switching and accessing the gnome shell overview using Neo. More precisely with Neo:

  • When any window has focus pressing alt and super has no effect whatsoever (neither alt - tab for application switching, alt - for window switching, or just super to get to the activities overview).
  • If now window is open super works fine. The same goes for when I'm in the activities overview.
  • Ctrl - Alt - F1 etc. works unaffected.

My system wide default keyboard layout is neo and I switch between keyboard layouts with setxkbmap de / setxkbmap de neo via a keyboard shortcut (the calculator button). When I switch to Qwertz everything works as expected.

I didn't find anything interesting in /var/log/{syslog, Xorg.0.log, gdm/*} and as far as I can tell there were no package installations at the time the problem started. I also tried removing the cache files /var/lib/xkb/* to no avail.

I'd also be happy about hint's how I can debug this phenomenon. As it it I'm at loss with what could be the cause.

Edit: If found a workaround: After logging out and logging in again everything works (my user get's automatically logged in after boot).

closed as off-topic by Elder Geek, Android Dev, David Foerster, Eric Carvalho, Kevin Bowen Aug 12 '16 at 18:46

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Elder Geek, Android Dev, David Foerster, Eric Carvalho
If this question can be reworded to fit the rules in the help center, please edit the question.

  • this bug is still there (as of Sep 2015) – vak Sep 9 '15 at 10:06
  • Seems related to askubuntu.com/questions/451945/… – user.dz Jan 20 '16 at 11:59
  • Keyboard may have inadvertently change state? May be related to activation of meta-key-combos e.g: Sticky Keys Or bounce-keys etc. Related Q: askubuntu.com/questions/301733/… – arielf Apr 12 '16 at 0:52
  • you could try this. Install xfce4 as additional window-manager first. Then reboot and login via xfce4. Test there how keys behave. When there is no dis-order with keys, then you could de-install gnome with gdm. Then wait until gnome is improved again (4 to 6 months). After this you could install gnome again. If this does not work, might be that keys got sticky by untidy living ?! – dschinn1001 May 14 '16 at 0:58
  • This happens occasionally in kde. If you don't wait long enough after boot things get messed up. Hard to know what it is. – walttheboss May 23 '16 at 7:43
0

sudo apt-get remove gnome-shell ubuntu-gnome-desktop and use sudo apt-get install bleachbit remove all Unwanted and install sudo apt-get install gnome-shell...ur done

-1

IF you go into the keyboard settings you should be able to rearrange them.. As well as that have you put a lil time into finding a possible external application that lets you use them in Gnome 3 for those alt and super keys? Sorry if this didn't help you much.

Not the answer you're looking for? Browse other questions tagged or ask your own question.