I ran the latest updates and as usual I had to re-install my video driver, download the headers and blah blah...

I ran into a few troubles that I was able to fix and at the end I got my Ubuntu up and running, Unity working, OpenGl working without a single problem... games running fine but wait.

I have only 1 worspace ! oooh no problem, lets ccsm to fix that... nope it has no effect. Well, we can activate the workspaces on dash --> Appearance... nope, nothing happends.

Oooooh yea, the dconf editor !! I will force those workspaces thru that method aaaaaand :/ nothing once again. :(

Maybe im missing something, maybe I missed something in this forum... but I cant find a way to fix those worspaces. I can only have 1 and thats it.

Does anyone had thtis problem before? Can I has my workspaces back? I only need 4 :(

  • I forgot to point out the fact that if I change the icon size inside appearance window... same result; nothing happends.
    – Solrac
    Jun 30, 2013 at 1:08

1 Answer 1


I managed to get my workspaces back :D

Solution is:

1.- Export your compiz config thru ccsm (if you lack of it just sudo apt-get install ccsm). 2.- Find the [core] section. 3.- Set the amount of workspaces with:

s0_hsize = 2
s0_vsize = 2

4.- Import your config back to compiz. 5.- Enjoy your workspaces.

This has to be done this way because ccsm lacks of some settings... this is one of them.

Not the answer you're looking for? Browse other questions tagged or ask your own question.