I've got a Asus TX300 running Ubuntu 13.04. This is a laptop tablet hybrid which has secondary battery in the dock. This battery is not detected by Ubuntu as far as I can see.

Ran this while docked:

user@TX300:/sys/devices/platform$ dmesg |grep batt
[    1.691787] ACPI: Battery Slot [BAT0] (battery present)

Also looked in /sys/class/power_supply/ and other tips I've found, but there's no trace of the extra battery.

Any help appreciated.

Edit:

I ran the battery all the way down until the unit suspended. When I closed the lid after it hibernated the led indicator changed from blinking to static, indicating it was charging. When I woke up this morning it had indeed been charged by the secondary battery but it still doesn't seem to be found by the OS.

  • I also get more battery life without dock than with dock, probably due to the hardware in dock consuming power without the dock battery being utilized. batterylife displayed with dock 3:53, without dock 5:16. – artothief Jun 30 '13 at 20:46
  • Sorry, no answer, but a pointer to LinLap page where this has been discussed and where hopefully someone might post something to make progress with this. linlap.com/asus_transformer_book_tx300 – user189947 Sep 4 '13 at 6:16

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.