I have a problem with Ubuntu 13.04.

I cannot log in to my account. I put the right password but there is an endless loop. (if i put wrong pass, it says "Invalid password..."). Also, it doesnt show the small drop down menu with choices "Gnome fallback, Default, etc.."

If i login as guest, the desktop is clear, no bars, no menus, anything. Just right clicks works only.

I have already try this solution ( chown username:username .Xauthority ) but there is no "Xauthority" at ubuntu 13.04. (?)

Is the problem about lightdm? Also, i tried sudo dpkg-reconfigure lightdm but it soesn't work.

I use the recovery mode (root command shell or something like this) in order to try the above commands.

Has anyone a solution?

Thank you.

  • I found shep's answer to be the most helpful here, and it's got negative votes. Perhaps some others should vote that puppy up. Oct 12, 2013 at 10:50

4 Answers 4


Try deleting $HOME/.profile, I had the same problem before, because I added a function into $HOME/.profile.

When I deleted the function, I could login again. The original content of $HOME/.profile is

# ~/.profile: executed by the command interpreter for login shells.
# This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login
# exists.
# see /usr/share/doc/bash/examples/startup-files for examples.
# the files are located in the bash-doc package.

# the default umask is set in /etc/profile; for setting the umask
# for ssh logins, install and configure the libpam-umask package.
#umask 022

# if running bash
if [ -n "$BASH_VERSION" ]; then
    # include .bashrc if it exists
    if [ -f "$HOME/.bashrc" ]; then
    . "$HOME/.bashrc"

# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/bin" ] ; then
  • Is this safe? If i delete '$HOME/.profile' will create any problem?
    – Fotis
    Jun 29, 2013 at 17:43
  • 1
    That's OK,or you can make the content of $HOME/.profile be default.
    – shep
    Jun 30, 2013 at 1:23
  • This was my solution. I had added a function to my .profile, and commenting that out did the trick. So I guess I need to put them in my .bashrc? Whacky. Oct 12, 2013 at 10:48

The file you need to make your own again is /home/[yourUsername]/.Xauthority (the . is important!). And be sure to follow the procedure in the first solution


I had a similar problem, but neither changing the ownership of ~/.Xauthority nor commenting the content of ~/.profile made a difference. To fix it I did the following

rm ~/.Xauthority
sudo apt-get install --reinstall xorg
sudo reboot

It took a little longer than normal to login, but I was able to. My guess is that the .Xauthority file became corrupted in some way.

  • Ah. For me, I had ssh'd into the machine from two different machines simultaneously, both with X11 forwarding. This fixed it! Also, I had set it up to not ask for my password and log me straight in; performing these fixes restored it to this behaviour
    – xxjjnn
    Oct 7, 2013 at 20:45

lightdm may be a good place to look. I had a similar problem in 12.04LTS and discovered a problem with Cairo-dock. Here's what I did:

boot login ->returns to lightdm login prompt

CTRL+ALT+F1 ->gets you to shell

sudo more /var/log/lightdm/lightdm.log

mine showed an error loading cairo-dock, followed by a couple of errors. You may get a different error, but it'll point you where to look next

Not the answer you're looking for? Browse other questions tagged or ask your own question.