Back in previous versions of Ubuntu I've removed Unity WebApps packages. Now I want to reinstall them.

I use Chromium, installed unity-chromium-extension package. Also reset default dconf settings (see screenshot below).

I'm currently trying to install Grooveshark webapp, as you see already included grooveshark.com domain in the dconf settings, also installed unity-webapps-grooveshark package, but still cant make WebApps work in Ubuntu.

Besides when I go to Chromium settings there is no Desktop Integration properties at all, though 'Unity WebApps Chromium extension" is enabled.

Any thoughts?

enter image description here

UPDATE (Also See UPDATE 2 below): After some package reinstallations I got this message when I visited twitter.com with Chromium:

enter image description here

When I accepted and opened Twitter app from the Dash it was opened as a standalone Chromium app, but there still were no additional Launcher options when I right-clicked the icon. I think it still hasn't integrated properly.

Update 2: I just tried to install Reddit app, accepted the confirmation box in Chromium but Reddit app has not appeared in the Dash. Seems above mentioned Twitter app was a remaining of the times before I removed packages.

  • Twitter might not have any additional Launcher options when you right click the icon. Try installing the Gmail webapp for instance, I think it has a "compose new email" in the Launcher right click. – Alaa Ali Jul 5 '13 at 9:49
  • @Alaa Already tried with no luck. – Otar Jul 5 '13 at 10:28
  • 1
    Is it creating application shortcut in ~/.local/share/applications? If not create it manually(from create-application-shortcut in chromium menu) & drag it to the launcher. Link. – Khurshid Alam Jul 5 '13 at 10:43
  • @KhurshidAlam I may be wrong, but seems you have Chromium apps in mind, I'm having problem with Unity WebApps. – Otar Jul 5 '13 at 11:09
  • 2
    True. But you can turn unity-web-apps into chromium-apps. Basically the same website is ruining in standalone mode. See Radu's answer below to understand what I am talking about. – Khurshid Alam Jul 5 '13 at 13:43

In Chromium, Desktop Integration is changed now to Installed Websites:


Installed Websites

Add integrated website

Firefox offers the same functionality through the General section:

Firefox Preferences

Until now you sow where you can find the exceptions for web applications and, implicitly, from where to remove this exceptions. Here is a list of sites that support integration in Ubuntu: http://www.omgubuntu.co.uk/2012/07/list-of-that-websites-support-unitys-new-web-apps-feature.

Related to Grooveshark Web App, according with this post, is not working for the new layout of the site.

Next you will see how to manually create a simple web application for the sites that doesn't offer integration in Ubuntu.

To add a new web application from Chromium, go to Tools > Create Application Shortcut...:

Create Application Shortcut

Add the application from desktop to Launcher by dragging and drop:

Application Shortcut


The last thing that you can do is to change the icon of application to a better one. To do this, search in Dash for alacarte to open Main Menu:


In Main Menu search for the application for which you want to change the icon:

change app icon


You probably need the desktop integration package:

sudo apt-get install unity-webapps-service

Reboot or log out and then back in and it should work.

  • 1
    Nah: "unity-webapps-service is already the newest version." – Otar Jul 2 '13 at 9:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.