Every time the system updates the kernel from 3.5.0-24 to 3.5.0-34 I get dropped into a busybox prompt at boot, but I can boot just fine using the previous kernel. I've tried all I know. I did a fsck.ext3 -f /dev/sdb2 using the alternate install CD. I've used boot-repair but to avail, I've checked for bad blocks but there are none. Should I purge the new kernel and use the old one instead? This is the output from boot-repair the first time, no purge. http://paste.ubuntu.com/5809230/

  • Do you have enough disk space? Purge the new kernel and reinstall it, and if it shows any error message include it in your question. Also, you can try kernel 3.8.0: sudo apt-get install linux-generic-lts-raring. – Eric Carvalho Jun 28 '13 at 23:34
  • @EricCarvalho I have more than enough disk space, I have almost 460GB left of 500GB. And there are no error messages, it just fails silently. I will try using the 3.8 kernel. – Victor Martinez Jun 29 '13 at 0:46
  • I installed the 3.8.0 kernel, but it failed on boot dropping me back into busybox. Just did a boot-repair, without purging the kernels. paste.ubuntu.com/5809521 Going to reboot, and see if it works now. – Victor Martinez Jun 29 '13 at 0:57
  • 3.8.0 didn't work. – Victor Martinez Jun 29 '13 at 1:10

Fixed it, using boot-repair, I added the kernel option rootdelay=90. Now the linux-kernel-3.5.0-34-generic-image. But after much research and testing, I have decided to go with the linux-generic image boots properly. which is kernel version 3.2.0-48. It's the only one that boots up correctly without having to add any kernel options. Also using this kernel solved another issue I had, which was a waking up took too long. Now waking up after suspend takes just 2 seconds as opposed to 10-20 seconds using the other images.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.