I'm very new to Ubuntu and to Linux in general, and took the leap and formatted my PC to Ubuntu 12.04 LTS very recently :)

I seem to be having some trouble getting my graphics card to run properly, I looked over what information I could find but I still cannot get it up and running and figured this was a good place to ask for help.

The information I can find on my graphics is as follows:

lspci outputs:

01:05.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RS880M [Mobility Radeon HD 4225/4250]
02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Madison [Mobility Radeon HD 5650/5750 / 6530M/6550M]

I tried using a mixture of the following links:

How do I fix my installation of ATI Catalyst Video Driver in 12.04 LTS?

What is the correct way to install proprietary ATI Catalyst Video Drivers (fglrx) directly from AMD?

Ubuntu Precise Installation Guide

But it does not seem to work, since running fglrxinfo in terminal gives:

display: :0.0
screen: 0
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 0x301)
OpenGL version string: 1.4 (2.1 Mesa 9.0.3)

What am I doing wrong here?

All help appreciated.

Edit: I have tried the legacy driver from http://www2.ati.com/drivers/linux/amd-driver-installer-catalyst-13-4-linux-x86.x86_64.zip

I also tried the guide at https://launchpad.net/~makson96/+archive/fglrx which caused the system to crash (blackscreen, no boot)

Neither seemed to work. I did however reinstall ubuntu 12.04 LTS, and re-tried both with no success.

Reinstalling ubuntu did however fix the broken dependencies problems, etc.


This is probably related to fglrx not working on your card. I had the same issue a while back. Install fglrx-legacy from this ppa: https://launchpad.net/~makson96/+archive/fglrx

  • I tried following your link, and the instructions, and this caused my system to more or less die (could not even boot). I figured it might have been because my system was kinda damaged after the stuff I'd tried, so I reinstalled Ubuntu (I had barely done anything since installation, anyway, except updates) and tried once more. Same results. My graphics card when I tested it, using this site: noobslab.com/2013/04/install-ati-amd-catalyst-drivers-in.html And the automatic hardware graphics card detection said 5000M Radeon 4200 Mobillity Series. Which mirrors the VGA 5000M / 4200. – user170974 Jun 29 '13 at 22:10

Try installing the software from this link. It is the latest proprietary Linux driver. If that doesn't work, it would be helpful to know the exact video card you have. Also, try updating your software. If that does not work, type sudo apt-get -f to fix dependency issues.

  • I tried that but it says it is not activated - I figured I had to try and purge my old driver, but that did not do the trick. I feel like I'm missing something incredibly obvious :p – user170974 Jun 28 '13 at 13:14
  • Well initially, before I started tampering with the system through the terminal I guess, I selected "ATI/AMD proprietary FGLRX graphics driver (post-release updates)" and installed it, rebooted and it said "Driver is installed but not activated" Now however I get this: Sorry, installation of this driver failed. Please have a look at the log file for details: /var/log/jockey.log – user170974 Jun 28 '13 at 13:18
  • How do I upload that? :P it's fairly long – user170974 Jun 28 '13 at 13:20
  • Its too long by about 760k characters, and snipping it as 'code' does not let me post that.. – user170974 Jun 28 '13 at 13:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.