1

I have a problem with Cloudify (both 2.5 and 2.6-rc release). I have an All-In-One Openstack 2013.1.1 setup and I'm trying to use Cloudify to bootstrap a cirros 0.3.1 vm.

My quantum configuration is:

  • pool of fixed ip (10.0.0.0/24) for vm management;
  • pool of floating ip (192.168.1.170-190) taken from 192.168.1.1/24 (my lan)

When I deploy a vm first, an ip from 10.0.0.0/24 is given (I cannot reach it from my PCs because it is only for vm management) and then I associate a floating ip with which I can ping (and ssh) the deployed machine.

The problem is when I do:

bootstrap-cloud openstack 

because Cloudify stay forever into "attempting to access management vm 10.0.0.3" and this is due to the fact that 10.0.0.3 is not reachable.

What can I do to get Cloudify take the floating ip instead of the fixed one?

3

You can configure private and public IP addresses in Cloudify as described here.

(This works only on Cloudify 2.6).

You also need to:

  1. Make sure that your Openstack provider supports auto assignment of floating IPs and that it has a default floating IPs pool name. (i.e.) The following two properties must be set in the nova.conf of your OpenStack cloud :

    default_floating_pool="nova"
    auto_assign_floating_ip = True
    
  2. Pass autoAssignFloatingIp : true in the options of the computeTemplate in the OpenStack cloud driver.

    Here's a working example of an Openstack cloud driver: You can use the cloud driver and its corresponding properties file "as is".

(Disclaimer: I am Tamir Korem, Cloudify Community Manager)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.