I have an Ubuntu 12.04 laptop from which I want to print in a Brother MFC-290C printer wired to a Win7 PC. Printer is already being shared by PC.

I've tried to install the printer via Alt+F2 system-config-printer, added it as a network Windows printer via SAMBA, verifyed access... BUT when asked for the manufacturer and model of the printer I found it was not available on the database.

Then I tried getting a .ppd file for my printer on the Brother site, found there were only .rpm and .deb options which I don't know how to handle.

Also I've tried Generic drivers like PCL6. Although installation was "successfully" completed, nothing happend when I ordered a Test Page.

Any guesses? Is my printer just too old?


I have a brother 290c. You need to follow the installation process as described in the step by step instructions on the Brother site. It installs the lpd driver, then a cups wrapper. If you do not follow the process, the driver will show in your system, but will not work.

Start here, and follow their instructions exactly for you printer model. http://welcome.solutions.brother.com/bsc/public/us/us/en/dlf/download_top.html?reg=us&prod=mfc290c_all&c=us&lang=en

Select your OS as Linux (deb) and go from there. Each page will also have links for additional help with the installation process.

  • As I've already changed my printer (not related with this problem) I can't exactly reproduce your answer. However, it looks good and as far as I can tell, I never came up with this options; so I think I'm going to mark it 'Accepted'. – jasikevicius23 Jan 16 '14 at 9:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.