2

I get this black bar across the bottom of my screen when ever I boot up, tried reboot and no joy, keep getting messages from docky telling me to "enable composting". Was using dual monitors before this happened, take the monitor out and i'm stuck with this

4

Docky requires a Compositing Window Manager to function properly. The black bar you see across the bottom is the area where Docky would be showing up if it could run. The usual compositing window manager for Ubuntu is Compiz, which can be enabled via System > Preferences > Appearance. From there you can try to enable "Normal" or "Extra" desktop effects in the "Visual Effects" tab.

If Compiz won't play nice with your graphics card, you can enable Metacity's compositing, which will at least allow Docky to run normally. To do this, press Alt+F2, then run gconf-editor. On the left side, browse to apps > metacity > general, then check the box next to "compositing_manager" on the right.

  • As a side note, I'm not sure why unplugging a monitor would break compositing, since it sounds like it must have been working before. You might want to try reconfiguring your monitor setup in System > Preferences > Monitors. – Michael Martin-Smucker Mar 21 '11 at 20:12
  • Actually, it fixed my problem. Using metacity is everything I need on this little box. – jfmessier Mar 28 '11 at 12:32
  • +1'd from me 2. You actually helped get past this issue on DEBIAN!!! – NlightNFotis Aug 6 '12 at 10:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy