4

I have tried various solutions available online

1) Added pcie_aspm=force to /etc/default/grub

2) Since Jupiter is no longer available in 13.04 , installed tlp

But still fan is making lot of sound (its running very fast I guess) and temperatures are around 60c (and sometimes even increasing) even on normal load. But on windows8, its fine. I bought the laptop just a week ago.

Even battery is very bad in Ubuntu. It hardly lasts for 2 hours on normal usage (which lasts for around 4 hours for same usage in Windows). How can I improve battery performance ?

Please help.

4
+150

Most likely the source of heat is not CPU, but video card. You notebook has 2 video cards, with the idea that slow but cool HD400 works by default, switching to hot and powerful one when needed. (which one do you have by the way? They vary in this model). In Linux, this does not work out of the box, and you always have both video cards on, resulting in maximum heat. If you are OK to go without big GPU, you can just disable bigger video card altogether. Intel HD4000 is a rather tough guy itself - it can handle HD video and all 2010 games quite well. Otherwise, search for instruction on how to tweak NVIDIA Optimus if you have NVIDIA, or PowerXPress if you have Radeon. These are the names of technologies that use 2 video cards to save power.

| improve this answer | |
  • Perfect! This is the solution. And to disable AMD graphic card/ switch between two graphic cards - follow this - askubuntu.com/questions/205112/… – mac Jul 15 '13 at 11:06
  • how to disable nvidia graphics? – Gacek Sep 30 '13 at 18:11
  • Possibly good news for some machines, following upgrade to Trusty Tahr: "How much the kernel update impacts your Ubuntu experience will depend a little bit on your hardware. For example, if you've got dual GPU hardware that uses Nvidia Optimus to switch between GPUs—one optimized for performance and the other for conserving power—the move from 12.04 to 14.04 will be huge. As of the 3.12 kernel, there's now low-level support of GPU switching (which should happen automatically)." – nutty about natty Aug 14 '14 at 9:20
0

Tweak CPU regime is the first. use TLP.

I helped to my Ubuntu 12.04 on much lower HW config by increasing amount of RAM and lowering swappines. I do not know if this could be your problem, so first analyse if the system is swapping (and unnecessarily heating your computer / if you have green HDD or SSD HDD). If this is it, try this guide: (http://www.howtogeek.com/115797/6-ways-to-speed-up-ubuntu/).

You can try to tweak some settings of your tlp by following this guide (Is there a power saving application similar to Jupiter?). Ideally, you can make some shell scripts running via launchers with different settings as powersave and performance.

Hope it helps.

| improve this answer | |
0

Try to enable powersaving for chipset and other devices:

sudo apt-get install powertop 
sudo powertop

Go to "tunables" tab and change all "bad" items to "good"

All changes reset after reboot. And some of them change depending on AC/Battery mode.

So you also have to make powertop changes permanent and disable pm-powersave scripts

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.